Closed Bug 1017129 Opened 5 years ago Closed 5 years ago

Polish undo close tab button toast appearance

Categories

(Firefox for Android :: Theme and Visual Design, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 32
Tracking Status
fennec 32+ ---

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(3 files)

Follow-up to bug 701725.

We should also audit the other button toasts to make sure they're consistently capitalized.
Duplicate of this bug: 1017501
Ian, can I get an icon for this? I will also gladly make any other necessary style changes :)
Flags: needinfo?(ibarlow)
Summary: Capitalize "Undo" action in undo closed tab button toast → Polish undo close tab button toast appearance
tracking-fennec: --- → ?
redirecting to antlam, who's been cranking out icons and keeping our visual style consistent.

margaret, can you a) audit other uses of ButtonToast here, and b) make sure I merged your oneline and ellipsize styles into ButtonMessage correctly?  I'm a good reviewer for this, too :)
Flags: needinfo?(ibarlow) → needinfo?(alam)
Anthony, mind putting an Undo icon together here? Should probably somewhat resemble what android uses http://cl.ly/image/1u0y2m3q2J3G
Haha. Jinx!
(In reply to Ian Barlow (:ibarlow) from comment #4)
> Anthony, mind putting an Undo icon together here? Should probably somewhat
> resemble what android uses http://cl.ly/image/1u0y2m3q2J3G

I see from this screenshot that v19+ toasts are transparent, looks like black and alpha is 50% or so.  antlam, what say you?  Can you give this a whirl on a v19+ and <v19 device?
(In reply to Nick Alexander :nalexander from comment #6)
> (In reply to Ian Barlow (:ibarlow) from comment #4)
> > Anthony, mind putting an Undo icon together here? Should probably somewhat
> > resemble what android uses http://cl.ly/image/1u0y2m3q2J3G
> 
> I see from this screenshot that v19+ toasts are transparent, looks like
> black and alpha is 50% or so.  antlam, what say you?  Can you give this a
> whirl on a v19+ and <v19 device?

In reply to both of yous - yes!

Nick, I've noticed this too. I was just going to say ours should probably be about the same transparency.
Flags: needinfo?(alam)
tracking-fennec: ? → 32+
Hey Margaret, I'm also noticing that the undo brings the "just closed" tab down to the bottom of the list. Is this intentional or? I'm thinking if it might be beneficial to restoring the tab to the previous order in the list.. thoughts?
tracking-fennec: 32+ → ?
Flags: needinfo?(margaret.leibovic)
Hey Margaret, I'm also noticing that the undo brings the "just closed" tab down to the bottom of the list. Is this intentional or? I'm thinking if it might be beneficial to restoring the tab to the previous order in the list.. thoughts?
(In reply to Anthony Lam (:antlam) from comment #9)
> Hey Margaret, I'm also noticing that the undo brings the "just closed" tab
> down to the bottom of the list. Is this intentional or? I'm thinking if it
> might be beneficial to restoring the tab to the previous order in the list..
> thoughts?

We should file a separate bug for that. That would require a fix to the session store code that stores and restores the tab.
Flags: needinfo?(margaret.leibovic)
Here goes the "undo" icon. I designed it to take from our existing forwards/backwards icon. I think the curved trajectory provides the idea of movement and really helps to keep it whimsical. 

As a side note, this also keeps our "types of arrows" count relatively low still and will draw a nice connection to an "export" arrow if we ever decide we need one prominently.
Attached file undo_icon.zip
Here they are from MDPI > XXHDPI
Attachment #8431251 - Flags: review?(nalexander)
I decided not to rev the string entity because this string just landed yesterday, so I don't think localizers would have looked at it yet. It also might not change in all locales. flod, can you tell me if this logic is wrong? If so, I'll update the patch to give the entity a new name.
Flags: needinfo?(francesco.lodolo)
I thought we set this to track 32 in triage today. Setting the flag now.
tracking-fennec: ? → 32+
Comment on attachment 8431251 [details] [diff] [review]
Polish undo close tab button toast appearance

Review of attachment 8431251 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm.  I suggest revving the entity anyway; if it's gone before l10n teams see it, that's fine.
Attachment #8431251 - Flags: review?(nalexander) → review+
(In reply to Nick Alexander :nalexander from comment #16)
> Comment on attachment 8431251 [details] [diff] [review]
> Polish undo close tab button toast appearance
> 
> Review of attachment 8431251 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> lgtm.  I suggest revving the entity anyway; if it's gone before l10n teams
> see it, that's fine.

Fair enough, it's not actually that much effort :)
Flags: needinfo?(francesco.lodolo)
The rule in general is to change the string ID if it already landed on mozilla-central. We have fast localizers, sometimes an hour is enough to get the strings localized ;-)
(In reply to Anthony Lam (:antlam) from comment #11)
> Created attachment 8431066 [details]
> Screen Shot 2014-05-29 at 12.57.22 PM.png
> 
> Here goes the "undo" icon. I designed it to take from our existing
> forwards/backwards icon. I think the curved trajectory provides the idea of
> movement and really helps to keep it whimsical. 
> 
> As a side note, this also keeps our "types of arrows" count relatively low
> still and will draw a nice connection to an "export" arrow if we ever decide
> we need one prominently.

I don't get the desire to go against platform convention. We can add the arrow head to the Android undo and harmonize the user experience. Here you're attempting to a/ redefine the undo icon completely. Check pretty much any application on any platform. And b/ require Android users to think about the action they're taking. That's two major negatives for very little upside.
https://hg.mozilla.org/mozilla-central/rev/3540dc826ca8
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
(In reply to Paul [pwd] from comment #20)

> I don't get the desire to go against platform convention. We can add the
> arrow head to the Android undo and harmonize the user experience. Here
> you're attempting to a/ redefine the undo icon completely. Check pretty much
> any application on any platform. And b/ require Android users to think about
> the action they're taking. That's two major negatives for very little upside.

An image search for "android undo" shows that the Google apps use the undo image you favor, but other applications use other undo images. I'm not sure it's a true platform convention yet.
(In reply to Mark Finkle (:mfinkle) from comment #22)
> (In reply to Paul [pwd] from comment #20)
> 
> > I don't get the desire to go against platform convention. We can add the
> > arrow head to the Android undo and harmonize the user experience. Here
> > you're attempting to a/ redefine the undo icon completely. Check pretty much
> > any application on any platform. And b/ require Android users to think about
> > the action they're taking. That's two major negatives for very little upside.
> 
> An image search for "android undo" shows that the Google apps use the undo
> image you favor, but other applications use other undo images. I'm not sure
> it's a true platform convention yet.

Image search "android reply"...
Thanks for your input, Paul. You're right, undo and reply icons are often used similarly, not just on Android but everywhere. It's worth remembering however that in this case the word "undo" is right next to the icon as well. :)  So I don't think we'll be making any changes here right away, but we will be watching for feedback from other users and can iterate if necessary. 

And as a matter of housekeeping, since this bug is now closed, any additional visual changes will be handled in separate follow ups.
Sorry Ian, one last comment as the icon in question kind of got implemented very quickly, then this was closed and I actually feel quite strongly about this. Every modern Android phone comes with Gmail, Email which both feature a reply button like our undo button and  with the addition of Chrome, an undo button that is also shipped in the icon pack. That's a huge precedence to go against. As stated before, there is clearly no upside to the current icon which goes against such a precedence (if one has been made, please point me to it). If we're relying on text to diminish ambiguity, we're clearly doing something wrong. Taking a closer look at the "Android Undo" image search result, reveals many of the 'reply' icons are from iOS and general web icon searches (please not there is no such ambiguity in the "Android Reply" image search results. We have a responsibility to provide users with a user experience that harmonises with the operating system and insistence on shipping the a reply icon for an undo action goes against that as much as waiting for feedback to fix a UX issue that need not make its way beyond the Nightly channel.
Yeah there is the Android drawable (ic_menu_revert) that we should be using (if it is public)
(In reply to Aaron Train [:aaronmt] from comment #26)
> Yeah there is the Android drawable (ic_menu_revert) that we should be using
> (if it is public)

These icons are meant for menus not toasts. We'd probably ship our own version of it if we do switch.
You need to log in before you can comment on or make changes to this bug.