Closed Bug 1017554 Opened 6 years ago Closed 6 years ago

Regression: Empty lists view, no data is shown or fetched

Categories

(Firefox for Android :: General, defect)

32 Branch
ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox30 --- unaffected
firefox31 --- unaffected
firefox32 --- verified
fennec 32+ ---

People

(Reporter: TeoVermesan, Assigned: Margaret)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, reproducible)

Steps to reproduce:
Install a home panel. (wikipedia, instagram, pocket)

Actual results:
- Feeds should be added to the home page.

Expected results:
- "No content could be found for this panel" is displayed on about:home
Blocks: lists
tracking-fennec: --- → ?
Flags: needinfo?(teodora.vermesan)
It might have been Bug 996708 that caused the regression.
Flags: needinfo?(teodora.vermesan)
Yeah, a regression window would be handy here.
Reproducible here too with the Wiki panel.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e017c15325ae&tochange=1e712b724d17

In the fx-team merge I see

25bad10a57c4	Margaret Leibovic — Bug 996708 - Set an explicit width/height for images in dynamic panel empty views. r=lucasr
Summary: Firefox Hub v2 are empty → Regression: Empty lists view, no data is shown or fetched
It seems weird that change caused this. I'll look into it.
Assignee: nobody → margaret.leibovic
tracking-fennec: ? → 32+
This was caused by bug 990066. I'm going to back out that patch.
Blocks: 990066
Fixed by the backout in bug 990066.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Device: LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 32.0a1 (2015-06-01)
Installing wikipedia, vimeo, etc. feeds are shown on the home page. 
But with pocket panel the Bug 1010986  is still reproducible.
I will mark the bug as verified fixed since the lists are not empty anymore.
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 32
Tested with:
Device: LG Nexus 4
OS: Android 4.4.2

Installing wikipedia, instagram, pocket, feeds are added to the home page, so:
Verified fixed on:
Build: Firefox for Android 32.0a2 (2014-07-14)
You need to log in before you can comment on or make changes to this bug.