[Flatfish] Only microphone available for WebRTC

RESOLVED FIXED

Status

Firefox OS
Gaia::Loop
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Raniere Silva, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][TCP])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140518030203

Steps to reproduce:

1. Enable internet connection
2. Open the web browser
3. Go to one of WebRTC video conference services (I tested with https://appear.in/tcp)


Actual results:

Browser requested: "Would you like to share your microphone with https://appear.in?".


Expected results:

Browser should requested: "Would you like to share your camera and microphone with https://appear.in?". This is what happens when I try using hamachi.
(Reporter)

Updated

4 years ago
Blocks: 903304
Same here, I tried it with appear.in and talky.io. In the both cases, I am asked if I can share the microphone, no mention of the camera.
Thanks for filing! I'll put a needinfo on myself to double check to see if we can confirm that this is a bug :)
Flags: needinfo?(feer56)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [Flatfish][TCP]

Comment 3

4 years ago
I tried it on a newer v1.4 from 2014-06-06 and it is working. I tested it per apprtc.appspot.com
I can reproduce this.  It seems that the cameras are not being recognized.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(feer56)
(In reply to Andrew Truong [:feer56] from comment #4)
> I can reproduce this.  It seems that the cameras are not being recognized.

Andrew,

What version of b2g are you using?

Comment 6

4 years ago
it was not working for me with the v1.4 from january that was coming with flatfish.
Component: Gaia::Browser → Gaia::Loop
(In reply to abhiram from comment #5)
> (In reply to Andrew Truong [:feer56] from comment #4)
> > I can reproduce this.  It seems that the cameras are not being recognized.
> 
> Andrew,
> 
> What version of b2g are you using?

The 1.4 version that came with the device.

Comment 8

4 years ago
Its fixed in the current version . I have just built 2.1.0 pre release and both the above mentioned sites were able to stream the video from the camera.
Hmm.. We need somebody to verify this. 
Maybe Caspy7 has some info..
Flags: needinfo?(caspy77)

Comment 10

4 years ago
Hi andrew,
what kind of verification do you need?
I was running flatfish with he v1.4 build from june 6th and now with a current build v2.1 and its working with both.
(Reporter)

Comment 11

4 years ago
Created attachment 8443454 [details]
camera.png

Work for me. See the screenshot of appear.in using from Flatfish and Firefox Nightly.

B2G: b91a268d3415fd5eec2fab45d3072067e8c0b33d
Gecko: a16e68c38aabd1d9c86c8a6fa4e8291dbefeb59e
Gaia: 8a239771e739f113241f20aa9566387adc824e0d

pavithran.s@gmail.com, at the screenshot Flatfish's record is rotate by 90º. Do you know this is already fixed or is a regression bug? The build that I try is two days old.
Flags: needinfo?(pavithran.s)

Comment 12

4 years ago
Hm, not sure what special insight I can bring, but I can say that when testing with https://appear.in/tcp that I was prompted to share mic and camera.
This is on a 2.0 build from May 19 (from _AtilA_).

From reviewing the comments it looks like this is broken in the factory build and the reporter's 1.4 build from May 18, but the 1.4 from June 6 is fine.

Whether the 1.4 fix landed after May 18 or there was an issue with that particular build I don't know.  I'm thinking if no one with more recent builds can reproduce this, it can be closed.

This will be better when we can get everyone on a more recent, standard build.  This is being worked on.

Also, I have been told that we are aiming at 2.0 with flatfish, so if something only exists on 1.4 but not 2.0 we probably want to prefer the latter.
Flags: needinfo?(caspy77)
Since 2.0 is aimed for Flatfish devices, I think it's safe to close this bug.
I'm confirming that this is fixed in version 2.0+ 
Clearing ni? flags. 
Resolving as fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(pavithran.s)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.