Closed Bug 1018163 Opened 8 years ago Closed 8 years ago

[Browser] Save image dialog styling looks broken

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

x86
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: wilsonpage, Assigned: pivanov)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files)

No description provided.
OS: Mac OS X → Gonk (Firefox OS)
Does this reproduce on a user build?
Keywords: qawanted
jsmith: Yes, reproducible on latest user build.
STEPS:

1. Open Browser App
2. Perform a Google image search
3. Tap and hold any image
4. Observe un-styled buttons
Ok - let's also check 1.4 to confirm this isn't reproducible there.
Duplicate of this bug: 1019629
Blocks: 1016987
Assignee: nobody → pivanov
Issue does NOT occur on Flame 1.4 or Buri 1.4

Result: Buttons appear styled as normal

Environmental Variables:
Device: Flame v1.4
BuildID: 20140603000203
Gaia: d108159874cb594e7068a5c8384f05f0a8910bfd
Gecko: 42d80aea48e3
Version: 30.0
Firmware Version: v10G-2

Environmental Variables:
Device: Buri v1.4 Mozilla RIL
BuildID: 20140603000203
Gaia: d108159874cb594e7068a5c8384f05f0a8910bfd
Gecko: 42d80aea48e3
Version: 30.0
Firmware Version: v1.2-device.cfg
Someone for VD should comment here if this is a blocker to shipping VD refresh in 2.0. My guess is that it is, but I'd like someone from UX to confirm.
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: regression
Attached file patch for Gaia/master
Attachment #8434314 - Flags: review?(bfrancis)
Flagging Patryk to comment on whether or not this is a VD blocker for 2.0.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(padamczyk)
I'd mark it as a blocker, looks terrible. And judging from the use cases of our emerging market users, they will see this dialog often.
Flags: needinfo?(padamczyk)
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1021393
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8434314 [details] [review]
patch for Gaia/master

Thanks Pavel :)

Travis errored so I restarted the job. Please wait for green to land.
Attachment #8434314 - Flags: review?(bfrancis) → review+
:) 

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/64ae6289f6de81878b9edd0279661b24f4831c64
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attached video video of issue verify
This issue has been verified successfully on Flame v2.0 & v2.1
STR:
1. Launch Browser and go to "www.google.com"
2. Select "Image"
3. Input "Krystal" and search
4. Tap a picture to check
5. Long press at the picture
**Buttons appear styled as normal
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        f9d6e3d83c3922e9399a6c27f5ce4cdd27bdfd05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/45112935086f
Build-ID        20141126000203
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.032754
FW-Date         Wed Nov 26 03:28:05 EST 2014
Bootloader      L1TC00011880

Flame 2.1 versions:
Gaia-Rev        db2e84860f5a7cc334464618c6ea9e92ff82e9dd
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/211eae88f119
Build-ID        20141126001202
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141126.033519
FW-Date         Wed Nov 26 03:35:30 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.