If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Save and Change Character Encoding dialog has no encodings

RESOLVED FIXED in seamonkey2.30

Status

SeaMonkey
Composer
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

unspecified
seamonkey2.30
regression

SeaMonkey Tracking Flags

(seamonkey2.28 unaffected, seamonkey2.29 fixed, seamonkey2.30 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Thanks to the magic of RDF, editor's change encoding dialog used to populate itself from the same data source as all of the character encoding menus that used to exist. Sadly people no longer get this and we have to reinvent the wheel all over again.
(Assignee)

Comment 1

3 years ago
Created attachment 8431630 [details] [diff] [review]
Proposed patch

I kept the tree as it's easier to select an item in a tree than a listbox.

CharsetMenu only provides methods to return a separate list of pinned and other charset info objects. I have to extract the charsets to ask for a single list, which it then gives to me in the correct order. (I then have to ask for the charsets again to find which one to select...)
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #8431630 - Flags: review?(iann_bugzilla)

Updated

3 years ago
Attachment #8431630 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 2

3 years ago
Oops, comm-central changeset 699551e9deae was for bug 1018263, not this bug.
(Assignee)

Comment 3

3 years ago
Pushed comm-central changeset e8d6763ac8d6.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-seamonkey2.28: --- → unaffected
status-seamonkey2.29: --- → affected
status-seamonkey2.30: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.30
(Assignee)

Comment 4

3 years ago
Comment on attachment 8431630 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 943252
User impact if declined: No encodings available
Testing completed (on m-c, etc.): Landed on c-c
Risk to taking this patch (and alternatives if risky): Low, rarely used
String changes made by this patch: None
Attachment #8431630 - Flags: approval-comm-aurora?

Updated

3 years ago
Attachment #8431630 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 5

3 years ago
http://hg.mozilla.org/releases/comm-aurora/rev/6ebeda3f772f
status-seamonkey2.29: affected → fixed
You need to log in before you can comment on or make changes to this bug.