If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

clean up font/shaper code to remove redundancy and dead mPlatformShaper field

RESOLVED FIXED in mozilla33

Status

()

Core
Graphics: Text
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
With the Windows-specific shapers gone, the only "platform shaper" we have left is Core Text, so it makes more sense to handle this entirely in the gfxMacFont subclass, and drop it from the generic gfxFont. (See bug 985220 comment 3.)

We can also clean up the gfx{backend}Font::ShapeText methods a bit, now that there are fewer platform-specific cases to handle.
(Assignee)

Updated

3 years ago
Depends on: 985220, 1018034
(Assignee)

Comment 1

3 years ago
Created attachment 8432054 [details] [diff] [review]
clean up redundancy in the font/shaper code.
Attachment #8432054 - Flags: review?(jdaggett)
(Assignee)

Updated

3 years ago
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
(Assignee)

Comment 2

3 years ago
Tryserver run: https://tbpl.mozilla.org/?tree=Try&rev=17806e23c6a5

Comment 3

3 years ago
Comment on attachment 8432054 [details] [diff] [review]
clean up redundancy in the font/shaper code.

Yay!
Attachment #8432054 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 4

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd9518344a23
OS: Mac OS X → All
Hardware: x86 → All
sorry had to backout this change for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=40847823&tree=Mozilla-Inbound
did now a re-checkin in https://hg.mozilla.org/integration/mozilla-inbound/rev/3e9d9aa535c7 since the test failures seems to be caused by the checkin before
https://hg.mozilla.org/mozilla-central/rev/3e9d9aa535c7
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
(Assignee)

Comment 8

3 years ago
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/0e387a554646 due to Thai regression described in bug 1020826.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Merge of backout:
https://hg.mozilla.org/mozilla-central/rev/0e387a554646
Target Milestone: mozilla32 → ---
(Assignee)

Comment 10

3 years ago
Re-landed:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ee3e74ba96a9
Target Milestone: --- → mozilla33
https://hg.mozilla.org/mozilla-central/rev/ee3e74ba96a9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.