New window opened from full-screen mode not maximized

NEW
Unassigned

Status

()

4 years ago
3 years ago

People

(Reporter: antigonos, Unassigned)

Tracking

29 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

1. Maximize Firefox
2. Step into full-screen mode (F11)
3. Open a new window (Ctrl-N)


Actual results:

New window is not maximized and also not full-screened.
It has the same dimension as the old window without maximization.


Expected results:

New window should be maximized too.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 210048

Comment 2

4 years ago
(In reply to YF (Yang) from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 210048 ***

I suspect this is rather a duplicate of bug 1005098, because comment #0 says  "also not full-screened".


Reporter, do you have the titlebar turned back on?
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(antigonos)
Resolution: DUPLICATE → ---

Comment 3

4 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> (In reply to YF (Yang) from comment #1)
> > 
> > *** This bug has been marked as a duplicate of bug 210048 ***
> 
> I suspect this is rather a duplicate of bug 1005098, because comment #0 says
> "also not full-screened".

No, I guess he meant the new window size are non-maximized and status are non-full-screen both.
I seems once reproduced the state yesterday, but can't reproduce now, the new window display as ordinary non-maximized window when full-screen now.

about bug 1005098, I don't see it relates to full-screen.
(Reporter)

Comment 4

4 years ago
Hi, I don't have titlebar (drawInTitlebar = true).
I think it is also not the (exact) duplicate of bug 210048, as in this case the window does not have maximized dimensions (but maybe something changed since 2010).

I try to explain this case with dimensions:
1. I have an FF (not maximized) window with say 500x400 pixels (just an example, not exact).
2. I maximize it -> now it has 1000x800 pixels and it is in maximized state.
3. If I open a new window now (Ctrl-N) it is also 1000x800 pixel large and in maximized state.
4. But if I switch to full screen (F11)...
5. ... and then open a new window, than it is again 500x400 pixel large (and of course not maximized), which I think is a bit disturbing, and it should also have 1000x800 pixels and maximized state.

It is not really a big issue, just thought it may deserve a report that you know about it.
Flags: needinfo?(antigonos)
Version 	43.0.4
Build ID 	20160105164030
User Agent 	Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

I can confirm this but I am not sure I agree it is a default.
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL
Ever confirmed: true
Product: Firefox → Core

Comment 6

3 years ago
The issue here is somewhere in XPFE's nsXULWindow code and the way that the various SetSize/SetPosition/SetPositionAndSize and LoadMiscPersistentAttributes and LoadPosition/SizeFromXUL methods interact. I don't really have time to investigate this further right now - it doesn't seem to be a particularly serious/problematic issue, and it might even be by design.
You need to log in before you can comment on or make changes to this bug.