Closed Bug 1018665 Opened 8 years ago Closed 8 years ago

ffsl missing after fix of Bug 999913

Categories

(Core :: Memory Allocator, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 965870

People

(Reporter: ekr, Unassigned)

Details

I am running into a compilation problem with B2G due to the
following commit:

https://hg.mozilla.org/mozilla-central/rev/a9f95997fe57

Current mozilla-central fails on my Linux (Ubuntu 12) box
with the following error:

../../../memory/jemalloc/src/include/jemalloc/internal/bitmap.h:133: error: undefined reference to 'ffsl'
../../../memory/jemalloc/src/include/jemalloc/internal/bitmap.h:137: error: undefined reference to 'ffsl'
collect2: error: ld returned 1 exit status

This is quite an old commit so I'm surprised nobody else is having trouble, but I verified it directly by building with just this change backed out.
You're building with --disable-optimize, aren't you?
Yes.
Technically with export B2G_NOOPT=1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 965870
You need to log in before you can comment on or make changes to this bug.