Closed Bug 1018720 Opened 6 years ago Closed 6 years ago

Translation infobar: missing HiDPI icon

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 33
Iteration:
33.3

People

(Reporter: soeren.hentzschel, Assigned: smacleod)

References

Details

(Whiteboard: [translation] )

Attachments

(8 files)

Attached image screenshot.png
The arrow icon in the select box needs a HiDPI version.
Flags: firefox-backlog+
Whiteboard: p=1
Sevaan, do we have a HiDPI version of this icon somewhere?
Flags: needinfo?(sfranks)
The arrow can be found in the assets mmaslaney has uploaded here: https://bugzilla.mozilla.org/show_bug.cgi?id=1024741#c7
Flags: needinfo?(sfranks)
(In reply to Sevaan Franks [:sevaan] from comment #2)
> The arrow can be found in the assets mmaslaney has uploaded here:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1024741#c7

Are we intentionally switching from a double arrow to a single arrow?
Assignee: nobody → smacleod
Status: NEW → ASSIGNED
Iteration: --- → 33.2
Points: --- → 1
QA Whiteboard: [qa+]
Whiteboard: p=1
Whiteboard: [translation]
(In reply to Florian Quèze [:florian] [:flo] from comment #3)
> (In reply to Sevaan Franks [:sevaan] from comment #2)
> > The arrow can be found in the assets mmaslaney has uploaded here:
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1024741#c7
> 
> Are we intentionally switching from a double arrow to a single arrow?

^ Sevaan?
Flags: needinfo?(sfranks)
QA Contact: bogdan.maris
(also, in-content we seem to have hi-dpi spinner-like icons for e.g. select boxes... don't know how hard it is to just steal that, and/or why this is a <menulist> rather than an html:select...)
Hey Steven, sorry for the late reply. Yes, that is the intention as we move toward a new, more unified style.

(In reply to Steven MacLeod [:smacleod] from comment #4)


> (In reply to Florian Quèze [:florian] [:flo] from comment #3)
> > (In reply to Sevaan Franks [:sevaan] from comment #2)
> > > The arrow can be found in the assets mmaslaney has uploaded here:
> > > https://bugzilla.mozilla.org/show_bug.cgi?id=1024741#c7
> > 
> > Are we intentionally switching from a double arrow to a single arrow?
> 
> ^ Sevaan?
Flags: needinfo?(sfranks)
Michael Maslaney, can you confirm the single arrow vs. double? Flo-retina pointed out that we are still using double-arrows in the Incontent UI stuff.
Flags: needinfo?(mmaslaney)
Attached file -Prompt-assets.zip
We are moving forward with the single arrow, attached.
Flags: needinfo?(mmaslaney)
This is a screenshot using the updated HiDPI icon provided. Is it just me or does it bother anyone else that the options menu uses a different arrow icon?

Thoughts?
Attachment #8450511 - Flags: feedback?(mmaslaney)
Attachment #8450511 - Flags: feedback?(florian)
Those arrows should definitely match.

A couple other things I can see:

- The background colour of the options button should match the language drop-down (there should be a very subtle gradient).
- The border of the language drop-down should match the border of the options button: #cdd3d8
- The language drop-down should be the same height as the options button (slightly larger)
(In reply to Sevaan Franks [:sevaan] from comment #10)

> - The language drop-down should be the same height as the options button
> (slightly larger)

We handled this in bug 1022405.
This patch switches the select box and adds a HiDPI variant. This pretty much brings things to the state of the previously posted screenshot.
Attachment #8451889 - Flags: review?(florian)
The patch in Bug 1028942 was incorrect. This patch fixes the buttons so that the options dropdown has the correct style as well.
Attachment #8451890 - Flags: review?(florian)
This makes the styling of the select dropdown match the options dropdown (and fixes the height).
Attachment #8451891 - Flags: review?(florian)
Finally, this updates the icon of the options dropdown to match the new select dropdown icon introduced in patch 1.
Attachment #8451893 - Flags: review?(florian)
This is a screenshot of the inforbar after applying the patches. The hover states of all the elements (excluding the "Translate" button) are now consistent as well.
Iteration: 33.2 → 33.3
That looks great, Steven. Thanks!
Attachment #8451889 - Flags: review?(florian) → review+
Attachment #8451890 - Flags: review?(florian) → review+
Attachment #8451891 - Flags: review?(florian) → review+
Attachment #8451893 - Flags: review?(florian) → review+
Comment on attachment 8450511 [details]
screenshot-select-box-icon.png

Next version looks much better..
Attachment #8450511 - Flags: feedback?(florian) → feedback-
We don`t have a Mac with Retina Display here, Sören can you please verify that the issue is fixed?
Flags: needinfo?(cadeyrn)
Yes, it looks good now. :)
Flags: needinfo?(cadeyrn)
Thanks a lot, marking this as verified then.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
Attachment #8450511 - Flags: feedback?(mmaslaney) → feedback+
You need to log in before you can comment on or make changes to this bug.