Facebook Contacts edit mode is not consistent nor correctly implemented according to the Visual Refresh specs

VERIFIED FIXED in Firefox OS v2.0

Status

--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmcf, Assigned: jmcf)

Tracking

({regression})

unspecified
2.0 S2 (23may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 fixed)

Details

Attachments

(1 attachment)

191 bytes, text/html
arcturus
: review+
arnau
: review+
Details
(Assignee)

Description

4 years ago
As a followup of bug 1017216, We need to reimplement all the VR corresponding to the edition of FB Contacts, as now is inconsistent and not compliant with the Visual Specifications. Also some cleaning of CSS rules is needed.
(Assignee)

Updated

4 years ago
Summary: Bad implementation of VR for edition of Facebook Contacts → Facebook Contacts edit mode is not consistent nor correctly implemented according to the Visual Refresh specs
(Assignee)

Updated

4 years ago
blocking-b2g: --- → 2.0?
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1018850
(Assignee)

Updated

4 years ago
Assignee: arnau → jmcf
(Assignee)

Comment 2

4 years ago
Created attachment 8432988 [details]
19863.html
Attachment #8432988 - Flags: review?(francisco)
Attachment #8432988 - Flags: review?(arnau)

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+

Updated

4 years ago
Keywords: regression
Comment on attachment 8432988 [details]
19863.html

Hi,

tested on the phone and working for me.

Would like to have a unit test for this. We didn't catch it before cause of the lack of unit tests for the contacts form.

If the test is complicated we should create a follow up and add the tests for this case.
Attachment #8432988 - Flags: review?(francisco) → review+
(Assignee)

Comment 4

4 years ago
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #3)
> Comment on attachment 8432988 [details]
> 19863.html
> 
> Hi,
> 
> tested on the phone and working for me.
> 
> Would like to have a unit test for this. We didn't catch it before cause of
> the lack of unit tests for the contacts form.
> 

We have form tests for Facebook. However we were not covering the organization field. I have added a new test devoted to it

> If the test is complicated we should create a follow up and add the tests
> for this case.
Comment on attachment 8432988 [details]
19863.html

Looks great! Thanks Jose Manuel :)
Attachment #8432988 - Flags: review?(arnau) → review+
(Assignee)

Comment 6

4 years ago
https://github.com/mozilla-b2g/gaia/commit/512bfcbecc07f976804efe7b7e0d3e63aa209286
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Keywords: verifyme
status-b2g-v2.0: --- → fixed
Target Milestone: --- → 2.0 S2 (23may)

Comment 7

4 years ago
verify with Flame KK v180 + v2.0 gaia/gecko, it's fine
Gaia      7edd3b0b9f65c3dde235c732d270e43e055a1254
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f3639e825b3b
BuildID   20140915135336
Version   32.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.