If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Homescreen crashes on loop

RESOLVED DUPLICATE of bug 1018406

Status

Firefox OS
Gaia::Homescreen
--
blocker
RESOLVED DUPLICATE of bug 1018406
3 years ago
3 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8432429 [details]
logcat.txt

It appears that immediately after flashing and completing the FTU the homescreen is crashing on a loop.

The last known good build was:
application_buildid: 20140530003925
application_changeset: e6f113c83095
gaia_changeset: 26d8fcab9b61f46451600f39c51e0387ef3c4f88

The issue then first appears in:
application_buildid: 20140530050928
application_changeset: 76432b693fc4
gaia_changeset: 26d8fcab9b61f46451600f39c51e0387ef3c4f88

The issue then appears to be resolved in:
application_buildid: 20140530124652
application_changeset: 50305ee11618
gaia_changeset: e98fe1e94d3d80ad36903500d8ca3333904b162c

And then regresses again in:
application_buildid: 20140530130452
application_changeset: 6f9eb2bb1103
gaia_changeset: e98fe1e94d3d80ad36903500d8ca3333904b162c

It then appears resolved again in:
application_buildid: 20140531031552
application_changeset: 85f6afe5cdde
gaia_changeset: e98fe1e94d3d80ad36903500d8ca3333904b162c

And finally regresses again in:
application_buildid: 20140531162052
application_changeset: fc91e69c3473
gaia_changeset: e98fe1e94d3d80ad36903500d8ca3333904b162c

This was picked up by our automation, which seems to fail when launching applications. The symptoms appear as any of the following, and maybe others:

JavascriptException: TypeError: this.app.element is null
JavascriptException: TypeError: GaiaApps.getActiveApp(...) is undefined

I've attached a logcat showing the initial crashing of the Homescreen app. This is then repeated on a loop once the user completes the FTU.
(Reporter)

Comment 1

3 years ago
The regression ranges don't appear to be particularly useful. I am however able to confirm the results manually. Perhaps this is an intermittent build issue? I'm hoping the logcat will prove useful.
(Reporter)

Updated

3 years ago
Blocks: 1018286
I can still reproduce this issue on todays(2014 06 02) flame build :

Gaia      e98fe1e94d3d80ad36903500d8ca3333904b162c
Gecko     https://hg.mozilla.org/mozilla-central/rev/d6fccb7c56a8
BuildID   20140602040201
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014
We can also see this in the Hamachi build:

Gaia      e98fe1e94d3d80ad36903500d8ca3333904b162c
Gecko     https://hg.mozilla.org/mozilla-central/rev/d6fccb7c56a8
BuildID   20140602040201
Version   32.0a1
ro.build.version.incremental=324
ro.build.date=Thu Dec 19 14:04:55 CST 2013
Duplicate of this bug: 1018956
From my dupe:
(In reply to Ben Hearsum [:bhearsum] from comment #2)
> Also, I heard other folks in #b2g complaining about this, so I moved Flame
> nightly updates to point at at a May 30th build again, because it's really
> tough to get out of this state without reflashing. If that's undesired, let
> me know. Otherwise I'll wait until we have a nightly with this fixed to
> re-enable them.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018406
You need to log in before you can comment on or make changes to this bug.