UI is basically non-functional on recent builds

RESOLVED DUPLICATE of bug 1018909

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1018909
4 years ago
4 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I flashed the 3am pacific build from June 1 this morning, and when I booted my home screen seemed to restart itself over and over again. I'm able to open apps if I do it really quickly, and they seem stable enough.

Here's what I got from logcat:
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
I/Gonk    (  323): Setting nice for pid 1573 to 1
I/Gonk    (  323): Changed nice for pid 1573 from 18 to 1.
I/Gonk    (  323): Setting nice for pid 1573 to 7
I/Gonk    (  323): Changed nice for pid 1573 from 1 to 7.
I/Gonk    (  323): Setting nice for pid 1573 to 1
I/Gonk    (  323): Changed nice for pid 1573 from 7 to 1.
I/Gonk    (  323): Setting nice for pid 1573 to 7
I/Gonk    (  323): Changed nice for pid 1573 from 1 to 7.
I/Gonk    (  323): Setting nice for pid 1573 to 1
I/Gonk    (  323): Changed nice for pid 1573 from 7 to 1.
D/skia    ( 1573): START /proc/cpuinfo:
D/skia    ( 1573): Processor	: ARMv7 Processor rev 3 (v7l)
D/skia    ( 1573): processor	: 0
D/skia    ( 1573): BogoMIPS	: 38.40
D/skia    ( 1573): 
D/skia    ( 1573): processor	: 1
D/skia    ( 1573): BogoMIPS	: 38.40
D/skia    ( 1573): 
D/skia    ( 1573): Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
D/skia    ( 1573): CPU implementer	: 0x41
D/skia    ( 1573): CPU architecture: 7
D/skia    ( 1573): CPU variant	: 0x0
D/skia    ( 1573): CPU part	: 0xc07
D/skia    ( 1573): CPU revision	: 3
D/skia    ( 1573): 
D/skia    ( 1573): Hardware	: Qualcomm MSM 8610 (Flattened Device Tree)
D/skia    ( 1573): Revision	: 0000
D/skia    ( 1573): Serial		: 0000000000000000
D/skia    ( 1573): 
D/skia    ( 1573): END /proc/cpuinfo
D/skia    ( 1573): Device supports ARM NEON instructions!
D/skia    ( 1531): START /proc/cpuinfo:
D/skia    ( 1531): Processor	: ARMv7 Processor rev 3 (v7l)
D/skia    ( 1531): processor	: 0
D/skia    ( 1531): BogoMIPS	: 38.40
D/skia    ( 1531): 
D/skia    ( 1531): processor	: 1
D/skia    ( 1531): BogoMIPS	: 38.40
D/skia    ( 1531): 
D/skia    ( 1531): Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
D/skia    ( 1531): CPU implementer	: 0x41
D/skia    ( 1531): CPU architecture: 7
D/skia    ( 1531): CPU variant	: 0x0
D/skia    ( 1531): CPU part	: 0xc07
D/skia    ( 1531): CPU revision	: 3
D/skia    ( 1531): 
D/skia    ( 1531): Hardware	: Qualcomm MSM 8610 (Flattened Device Tree)
D/skia    ( 1531): Revision	: 0000
D/skia    ( 1531): Serial		: 0000000000000000
D/skia    ( 1531): 
D/skia    ( 1531): END /proc/cpuinfo
D/skia    ( 1531): Device supports ARM NEON instructions!
I/Gonk    (  323): Setting nice for pid 1089 to 18
I/Gonk    (  323): Changed nice for pid 1089 from 18 to 18.
I/Gonk    (  323): Setting nice for pid 1531 to 18
I/Gonk    (  323): Changed nice for pid 1531 from 1 to 18.
I/LOWI-SERVER(  451): [LOWIController] OSAgent Subscription timer, check and issue subscription request
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [LOWI-SERVER] unknown deliver target [OS-Agent]
I/Gecko   (  323): IPDL protocol error: Handler for PIndexedDBDatabase returned error code
I/Gecko   (  323): [Parent 323] WARNING: waitpid failed pid:1573 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][DispatchAsyncMessage] Error: Processing error: message was deserialized, but the handler returned false (indicating failure)
I/Gecko   (  323): 
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): [Parent 323] WARNING: pipe error (220): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 450
I/Gonk    (  323): Setting nice for pid 1810 to 18
I/Gonk    (  323): Changed nice for pid 1810 from 0 to 18.
I/Gonk    (  323): Setting nice for pid 1810 to 1
I/Gonk    (  323): Changed nice for pid 1810 from 18 to 1.
I/Gecko   ( 1810): ###################################### forms.js loaded
I/Gecko   ( 1810): ############################### browserElementPanning.js loaded
I/Gecko   ( 1810): ######################## BrowserElementChildPreload.js loaded
D/skia    ( 1810): START /proc/cpuinfo:
D/skia    ( 1810): Processor	: ARMv7 Processor rev 3 (v7l)
D/skia    ( 1810): processor	: 0
D/skia    ( 1810): BogoMIPS	: 38.40
D/skia    ( 1810): 
D/skia    ( 1810): processor	: 1
D/skia    ( 1810): BogoMIPS	: 38.40
D/skia    ( 1810): 
D/skia    ( 1810): Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
D/skia    ( 1810): CPU implementer	: 0x41
D/skia    ( 1810): CPU architecture: 7
D/skia    ( 1810): CPU variant	: 0x0
D/skia    ( 1810): CPU part	: 0xc07
D/skia    ( 1810): CPU revision	: 3
D/skia    ( 1810): 
D/skia    ( 1810): Hardware	: Qualcomm MSM 8610 (Flattened Device Tree)
D/skia    ( 1810): Revision	: 0000
D/skia    ( 1810): Serial		: 0000000000000000
D/skia    ( 1810): 
D/skia    ( 1810): END /proc/cpuinfo
D/skia    ( 1810): Device supports ARM NEON instructions!
I/Gecko   (  323): IPDL protocol error: Handler for PIndexedDBDatabase returned error code
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][DispatchAsyncMessage] Error: Processing error: message was deserialized, but the handler returned false (indicating failure)
I/Gecko   (  323): 
I/Gecko   (  323): [Parent 323] WARNING: waitpid failed pid:1810 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): [Parent 323] WARNING: pipe error (175): Connection reset by peer: file ../../../gecko/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 450
I/Gonk    (  323): Setting nice for pid 1851 to 18
I/Gonk    (  323): Changed nice for pid 1851 from 0 to 18.
I/Gonk    (  323): Setting nice for pid 1851 to 1
I/Gonk    (  323): Changed nice for pid 1851 from 18 to 1.
I/Gecko   (  323): *** UTM:SVC TimerManager:notify - notified @mozilla.org/b2g/webapps-update-timer;1
I/Gonk    (  323): Setting nice for pid 1865 to 18
I/Gonk    (  323): Changed nice for pid 1865 from 0 to 18.
I/Gecko   ( 1851): ###################################### forms.js loaded
I/Gecko   ( 1851): ############################### browserElementPanning.js loaded
I/Gecko   ( 1851): ######################## BrowserElementChildPreload.js loaded
I/Gecko   ( 1865): ###################################### forms.js loaded
I/Gecko   ( 1865): ############################### browserElementPanning.js loaded
I/Gecko   ( 1865): ######################## BrowserElementChildPreload.js loaded
D/skia    ( 1851): START /proc/cpuinfo:
D/skia    ( 1851): Processor	: ARMv7 Processor rev 3 (v7l)
D/skia    ( 1851): processor	: 0
D/skia    ( 1851): BogoMIPS	: 38.40
D/skia    ( 1851): 
D/skia    ( 1851): processor	: 1
D/skia    ( 1851): BogoMIPS	: 38.40
D/skia    ( 1851): 
D/skia    ( 1851): Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
D/skia    ( 1851): CPU implementer	: 0x41
D/skia    ( 1851): CPU architecture: 7
D/skia    ( 1851): CPU variant	: 0x0
D/skia    ( 1851): CPU part	: 0xc07
D/skia    ( 1851): CPU revision	: 3
D/skia    ( 1851): 
D/skia    ( 1851): Hardware	: Qualcomm MSM 8610 (Flattened Device Tree)
D/skia    ( 1851): Revision	: 0000
D/skia    ( 1851): Serial		: 0000000000000000
D/skia    ( 1851): 
D/skia    ( 1851): END /proc/cpuinfo
D/skia    ( 1851): Device supports ARM NEON instructions!
I/Gecko   (  323): IPDL protocol error: Handler for PIndexedDBDatabase returned error code
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][DispatchAsyncMessage] Error: Processing error: message was deserialized, but the handler returned false (indicating failure)
I/Gecko   (  323): 
I/Gecko   (  323): [Parent 323] WARNING: waitpid failed pid:1851 errno:10: file ../../../gecko/ipc/chromium/src/base/process_util_posix.cc, line 261
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gecko   (  323): 
I/Gecko   (  323): ###!!! [Parent][MessageChannel] Error: Channel error: cannot send/recv
I/Gecko   (  323): 
I/Gonk    (  323): Setting nice for pid 1865 to 1
I/Gonk    (  323): Changed nice for pid 1865 from 18 to 1.
I/Gonk    (  323): Setting nice for pid 1865 to 7
I/Gonk    (  323): Changed nice for pid 1865 from 1 to 7.
I/Gonk    (  323): Setting nice for pid 1865 to 1
I/Gonk    (  323): Changed nice for pid 1865 from 7 to 1.
I/Gonk    (  323): Setting nice for pid 1865 to 7
I/Gonk    (  323): Changed nice for pid 1865 from 1 to 7.
I/Gonk    (  323): Setting nice for pid 1865 to 1
I/Gonk    (  323): Changed nice for pid 1865 from 7 to 1.
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWiFi-PE] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XT-CS] unknown deliver target [OS-Agent]
E/QCALOG  (  441): [MessageQ] ProcessNewMessage: [XTWWAN-PE] unknown deliver target [OS-Agent]
I/Gonk    (  323): Setting nice for pid 1913 to 18
I/Gonk    (  323): Changed nice for pid 1913 from 0 to 18.
D/skia    ( 1865): START /proc/cpuinfo:
D/skia    ( 1865): Processor	: ARMv7 Processor rev 3 (v7l)
D/skia    ( 1865): processor	: 0
D/skia    ( 1865): BogoMIPS	: 38.40
D/skia    ( 1865): 
D/skia    ( 1865): processor	: 1
D/skia    ( 1865): BogoMIPS	: 38.40
D/skia    ( 1865): 
D/skia    ( 1865): Features	: swp half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt 
D/skia    ( 1865): CPU implementer	: 0x41
D/skia    ( 1865): CPU architecture: 7
D/skia    ( 1865): CPU variant	: 0x0
D/skia    ( 1865): CPU part	: 0xc07
D/skia    ( 1865): CPU revision	: 3
D/skia    ( 1865): 
D/skia    ( 1865): Hardware	: Qualcomm MSM 8610 (Flattened Device Tree)
D/skia    ( 1865): Revision	: 0000
D/skia    ( 1865): Serial		: 0000000000000000
D/skia    ( 1865): 
D/skia    ( 1865): END /proc/cpuinfo
D/skia    ( 1865): Device supports ARM NEON instructions!
To be noticed that my very same build is fine on my Flame but exposes the same issue on Janx' one.
(Reporter)

Comment 2

4 years ago
Also, I heard other folks in #b2g complaining about this, so I moved Flame nightly updates to point at at a May 30th build again, because it's really tough to get out of this state without reflashing. If that's undesired, let me know. Otherwise I'll wait until we have a nightly with this fixed to re-enable them.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018909
You need to log in before you can comment on or make changes to this bug.