Closed Bug 1019757 Opened 7 years ago Closed 3 years ago

[B2G][Tarako][Contacts]Add New Contact transition screen not graceful

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected, b2g-v1.4 unaffected)

RESOLVED WONTFIX
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected
b2g-v1.4 --- unaffected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Firewatch Log
User taps Contacts App and plus sign to Add contact. After entering a name and tapping Done, first the disappearing keyboard briefly yields a black box.  However, simultaneously, the header for Contacts slides down as well causing a double vision effect of two slide down transitions. 

Repro Steps: 
1) Update a Tarako to BuildID: 20140602014001
2) Tap Contacts and New Contact
3) Complete at least one Name field and select Done
4) Observe device behavior

Actual: 
First the disappearing keyboard briefly yields a black box.  However, simultaneously, the header for Contacts slides down as well causing a double vision effect of two slide down transitions. 

Expected: 
Graceful transition between screens.


Notes: 
Repro frequency: (5/5, 100%) 

See attached: video = https://www.youtube.com/watch?v=gXqmI-auR0k, logcat, firewatch

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140603014004
Gaia: fbead7b3bafb865fbbf269c6cd53ac1866f64f27
Gecko: dbdc98109fef
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
This issue does not reproduce on 1.4 Flame following STR from Comment 0. Graceful transition is visible during the transition screens. 

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
This issue does not reproduce on 1.3 Buri following STR from Comment 0. Graceful transition is visible during transition screens. 

1.3 Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140529024024 
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42 
Gecko: 42ef074f380f 
Version: 28.0 
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
The video looks like the notification drop down was pulled slightly. 0:17

The black box is the keyboard being dismissed; which I think is a duplicate of bug 1001541
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1001541
Actually, maybe I was a little hasty in stating it's a duplicate.  It may help to create a profile to see what might be causing a delay, considering that 1.3/1.4 isn't showing the issue.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 7 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.