[B2G][Email]: Unable to download attachments of unsupported filetypes

RESOLVED DUPLICATE of bug 825318

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 825318
4 years ago
4 years ago

People

(Reporter: Warren Holdsworth, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-1])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8433503 [details]
Buri 2.0_emailattachment_Logcat

Description:
Email attachments of unsupported file cannot be downloaded onto the device.

Repro Steps:
1) Update a Flame to BuildID: 20140530040207
2) Log into an email account
3) Send the account an email with an unsupported file as an attachment
4 [review]) Open the email on the DUT
5) Observe that the attachment is displayed but is not available for download

Actual:
Email attachments for unsupported filetypes are not able to be downloaded on the device.

Expected:
Email attachments should be able to be downloaded even when unsupported by the device.

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v10g-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 100%
Link to failed test case:
See attached:
Buri 2.0_emailattachment_Logcat
Email_txt_attachment.png

Flame Logcat not included due to issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1010993

Notes:
Successfully able to download JPG, MP3

No download option for: txt, xls, plain text document
(Reporter)

Comment 1

4 years ago
Created attachment 8433504 [details]
email_txt_attachment.png

Buri 2.0, Buri 1.4, Buri 1.3: Unsupported filetypes can not be downloaded.

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140530024008
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 57cd741e4d0b
Version: 28.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
(Reporter)

Updated

4 years ago
Whiteboard: [2.0-flame-test-run-1]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825318
You need to log in before you can comment on or make changes to this bug.