Improve toolbar's 'search' state visual when it is active

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: antlam, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
NOT a bug about improving the search experience, just the magnifying glass icon's showing and hiding interaction.

I think it's worth experimenting with this interaction to see if we can provide a little more context to the user (when in active state) and maybe even drive up search usage (and avoid googling 'google'). 

Currently, there's a Firefox/Nightly icon - it disappears when the keyboard is up and the field is active. The only indicator of some sort of "search" capability is via the placeholder text (which disappears too as soon as the user begins to type) that reads "Enter Search or Address".
(In reply to Anthony Lam (:antlam) from comment #0)
> Created attachment 8433620 [details]
> preview_url_active.png
> 
> NOT a bug about improving the search experience, just the magnifying glass
> icon's showing and hiding interaction.
> 
> I think it's worth experimenting with this interaction to see if we can
> provide a little more context to the user (when in active state) and maybe
> even drive up search usage (and avoid googling 'google'). 
> 
> Currently, there's a Firefox/Nightly icon - it disappears when the keyboard
> is up and the field is active. The only indicator of some sort of "search"
> capability is via the placeholder text (which disappears too as soon as the
> user begins to type) that reads "Enter Search or Address".

This looks nice ANthony. 

My only challenge to this idea would be, is this communicating the right thing if I am typing an actual URL, and not searching?
Also a note: We could not reliably tell all keyboards to switch between "search" and "go" modes so we removed the mode switch. We removed the "->" and "magnify glass" icons in the URLBar too.
(Reporter)

Comment 3

5 years ago
Not sure if we want to put this on our radar Lucas, thoughts?

I think even if we can't tell, the Awesomebar could use some indicator to show how awesome it is. But, I could also be convinced otherwise since this doesn't seem to be a big issue to my knowledge..
Flags: needinfo?(lucasr.at.mozilla)
(Reporter)

Updated

5 years ago
I think the orange border when focused is enough to convey the different state. But we can experiment with a few options. Definitely v2 material though.
Blocks: new-toolbar-v2
No longer blocks: new-toolbar-v1
Flags: needinfo?(lucasr.at.mozilla)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.