Closed Bug 1019961 Opened 5 years ago Closed 5 years ago

[B2G][Tarako][Connect A2]Indefinite wait period following registration

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected, b2g-v1.4 affected)

RESOLVED DUPLICATE of bug 1005828
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected
b2g-v1.4 --- affected

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Firewatch Log
User downloads and installs Connect A2 from Marketplace and launches App. When user completes the registration, a wait message occurs indefinitely until user tries the same procedure on a second device. Then the Wait message turns into an incomplete 'failure' error message. 

Prerequisites:
1. Download and install Connect A2 from Marketplace

Repro Steps: 
1) Update a Tarako to BuildID: 20140603014004
2) Tap Connect A2 and agree to Terms of Use
3) Fill in nickname, Country, phone number and select WhatsappNet and Register
4) Observe behavior on primary device

Actual: 
Indefinite wait period. Workaround is to try same Repro Steps 1-3 above on a second device to cause the primary device to display an error message of “failure”

Expected: 
Connection with list of Contacts shown – Buri 1.3 was near immediate.

Notes: Video from 1:30 mark to the 5:05 mark shows wait period example. 5:06 to the end shows failure message after introducing second device performing STR.

Logcat is for a near 20 minute example. Firewatch is for a near 20 minute example. 

Repro frequency: (5/5, 100%) 

See attached: video = https://www.youtube.com/watch?v=_qom5B_uL3w, logcat, firewatch

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140603014004
Gaia: fbead7b3bafb865fbbf269c6cd53ac1866f64f27
Gecko: dbdc98109fef
Version: 28.1
Firmware Version: sp6821a-gonk-4.0-5-12
User Agent: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
This issue does not reproduce on 1.3 Buri following the STR from Comment 0. There was nearly no wait period and contacts appeared. 

1.3 Environmental Variables: 
Device: Buri 1.3 MOZ 
BuildID: 20140529024024 
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42 
Gecko: 42ef074f380f 
Version: 28.0 
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
This issue does reproduce on 1.4 Flame following STR from Comment 0. Indefinite wait period occurred following registration and contacts did not appear after a 2 minute wait. 

1.4F Environmental Variables:
Device: Flame 1.4F
BuildID: 20140529000204
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Gecko: 2181cac4d0fc
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Component: Mobile → Preinstalled B2G Apps
The video included here is too long. What we really need to see a video of the bug here specifically that is shorter & another video that shows that bug not reproducing on 1.3.
Component: Preinstalled B2G Apps → General
Product: Tech Evangelism → Firefox OS
Keywords: qawanted
Start of waiting period : http://youtu.be/_qom5B_uL3w?t=1m34s
Failure message : http://youtu.be/_qom5B_uL3w?t=4m55s
looking at the video it takes about 3 minutes and 21 seconds to show a failure from ConnectA2.

Looking at today's build; 1.3 Buri took less than one second to read in the contact within connecta2 ( V -> new chat -> refresh )

Tarako is not able to.  I think there might might be an issue with how ConnectA2 is trying to get the contacts on Tarako versus how it's trying to get it on Buri.

Julien, is there any difference in getting contacts in 1.3T than on 1.3?  Otherwise this may be a ConnectA2 issue...  is there any way of getting that information in logcat?
Flags: needinfo?(felash)
Previous testing comment's build environments:

Gaia      e073132c427e85f15408c5d9a9c700b20ee12b8b
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/rev/d78bccbc2a24
BuildID   20140613014003
Version   28.1
ro.build.version.incremental=eng.cltbld.20140613.133443
ro.build.date=Fri Jun 13 13:34:53 EDT 2014
Tarako

Gaia      8d6bd6c484557c5322bf14798a4273d2a8f4300f
Gecko     https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/d0c6d2ebfe65
BuildID   20140613024000
Version   28.0
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013
Buri
Nom'ing as 1.3T? because it could be an issue on our end...
blocking-b2g: --- → 1.3T?
Flags: needinfo?(james.zhang)
I think it's connectA2 issue, let's track the bug 1005828 and ask owner to fix it and provide new version.
Depends on: 1005828
Flags: needinfo?(james.zhang) → needinfo?(yang.zhao)
(In reply to James Zhang (Spreadtrum) from comment #8)
> I think it's connectA2 issue, let's track the bug 1005828 and ask owner to
> fix it and provide new version.

Hello,

First issue: 'wait message occurs indefinitely'. Could you please specify the waiting message? "Waiting for network" or "loading..."?
 
Second issue: 'failure' is not an issue. This error is thrown when you use the same telephone number to register. You should uninstall ConnectA2 before to use the same telephone number for registration. (Maybe it is necessary a better error description, we include this as P4 in our bug list).

Juanma
Flags: needinfo?(nhirata.bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #5)

> Julien, is there any difference in getting contacts in 1.3T than on 1.3? 
> Otherwise this may be a ConnectA2 issue...  is there any way of getting that
> information in logcat?

No, there shouldn't be any difference.

Where is the related code in ConnectA2? I can have a look.
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #10)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #5)
> 
> > Julien, is there any difference in getting contacts in 1.3T than on 1.3? 
> > Otherwise this may be a ConnectA2 issue...  is there any way of getting that
> > information in logcat?
> 
> No, there shouldn't be any difference.
> 
> Where is the related code in ConnectA2? I can have a look.

First issue (wait) was due to OOM. We have implemented a lazy load process to avoid this OOM in ConnectA2 v16.

ConnectA2 v16 --> https://bugzilla.mozilla.org/attachment.cgi?id=8440468

Juanma
Ah ok.  Sorry, julien; thanks for the information.  Based on what James and Juanma stated, I will mark this as a dup of bug 1005828 since we're tracking that bug.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1005828
Let's track it in 1005828.
Flags: needinfo?(yang.zhao)
blocking-b2g: 1.3T? → ---
Depends on: 1055993
You need to log in before you can comment on or make changes to this bug.