Closed Bug 1020023 Opened 6 years ago Closed 6 years ago

update a user's last-visited timestamp for a bug when they perform any actions on it

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 5.0

People

(Reporter: ehsan, Assigned: glob)

References

Details

Attachments

(1 file)

So I'm been using Updated Since Last Visit for a few hours now, and it works great!  But there is one glitch which I think hurts the usefulness of the feature (although it's probably very specific to my workflow so it should not block the announcement of this feature to a wider audience in any way!)

I use the Bugzilla Helper add-on quite heavily in order to be able to comment on bugs from within Thunderbird.  That add-on works using (I think) the XML-RPC API to post a comment on my behalf to bugs.  The bugs that I comment on that way now show up in the Updated Since Last Visit list, which means I keep looking at my own comments.  :-)

I think a simple fix to this bug would be to make the act of commenting on a bug through the API(s) (or really making any change to the bug, but commenting is what affects me immediately) count as a visit to the bug.

What do you guys think?
(In reply to :Ehsan Akhgari (lagging on bugmail, needinfo? me!) from comment #0)
> I think a simple fix to this bug would be to make the act of commenting on a
> bug through the API(s) (or really making any change to the bug, but
> commenting is what affects me immediately) count as a visit to the bug.

makes sense, updating summary and moving upstream.
Assignee: nobody → create-and-change
Component: Extensions: MyDashboard → Creating/Changing Bugs
Depends on: 489028
OS: Mac OS X → All
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: default-qa
Hardware: x86 → All
Summary: Make "Updated Since Last Visit" smarter by ignoring comments made by the user himself → update a user's last-visited timestamp for a bug when they perform any actions on it
Version: Production → unspecified
Attached patch 1020023_1.patchSplinter Review
Assignee: create-and-change → glob
Status: NEW → ASSIGNED
Attachment #8433885 - Flags: review?(dkl)
Comment on attachment 8433885 [details] [diff] [review]
1020023_1.patch

Review of attachment 8433885 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #8433885 - Flags: review?(dkl) → review+
Flags: approval?
Flags: approval? → approval+
Target Milestone: --- → Bugzilla 5.0
To ssh://gitolite3@git.mozilla.org/bugzilla/bugzilla.git
   15b70d2..66c3f7d  master -> master
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1022345
Blocks: 1111043
You need to log in before you can comment on or make changes to this bug.