Closed Bug 1020095 Opened 6 years ago Closed 6 years ago

[Flame] Keyboard sticks on screen after leaving layout switcher

Categories

(Firefox OS Graveyard :: Gaia::System::Input Mgmt, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: jj.evelyn, Assigned: timdream)

References

Details

(Keywords: regression, Whiteboard: [p=1])

Attachments

(1 file, 1 obsolete file)

STR:
1. focus on an input field and a keyboard layout shows
2. drag down utility tray and click on layout switcher
3. dismiss the 'Select' dialog displayed by layout switcher, then you will be brought back to the original input field

Expected Result:
the input field is still focused, and you can unfocus it to hide keyboard

Actual Result:
the input field lost focus but keyboard is still there, so there is not mean to hide keyboard.
I wonder if this is a regression of bug 1018590 ... will confirm that.
Assignee: nobody → timdream
Keywords: regression
Yes. The bug is gone after I revert the patch.
Depends on: 1018590
Comment on attachment 8433875 [details] [review]
mozilla-b2g:master PR#19979

Rudy, can this review cut in line since this is a blocking regression?

The proper fix of this bug should be moving the IMESwitcher controller to another module and properly cover it with tests, but for 2.0 I think this is the sensible thing to do instead.
Attachment #8433875 - Flags: review?(rlu)
Status: NEW → ASSIGNED
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S3 (6june)
Comment on attachment 8433875 [details] [review]
mozilla-b2g:master PR#19979

Yes, this patch could fix this issue.
However, I found another issue which might also be related to the same regression bug, bug 1018590.

STR
===
1. Launch keyboard.
2. use IME switching function in utility tray to switch to demo-keyboard (another app).
3. switching back to built-in keyboard again.
   => Found that cannot switch back.

Please let me know if I need to take over this bug to address the above issue.

Thanks.
Attachment #8433875 - Flags: review?(rlu)
Comment on attachment 8433948 [details] [review]
mozilla-b2g:master PR#19986

Thanks for catching the problem. How about this?
Attachment #8433948 - Flags: review?(rlu)
Attachment #8433875 - Attachment is obsolete: true
Comment on attachment 8433948 [details] [review]
mozilla-b2g:master PR#19986

r=me with the comment addressed.

Tim, thanks.
Attachment #8433948 - Flags: review?(rlu) → review+
blocking-b2g: 2.0? → 2.0+
master: https://github.com/mozilla-b2g/gaia/commit/877c2fd081c4fba46ba56b87705cb40296ef20ec
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.