Closed Bug 1020338 Opened 8 years ago Closed 3 years ago

Missing and incorrect accessibility events when selection changes in address autocomplete

Categories

(Thunderbird :: Disability Access, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jdiggs, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Steps to reproduce:
1. Launch the attached accessible-event listener in a terminal
2. Press Ctrl+N in Thunderbird to compose a new message
3. Type a character in the To: field causing the autocomplete to appear
4. Arrow Down amongst all the items in the autocomplete

Expected results: An accessible event would be emitted each time the selected item changes within the displayed autocompletion list. Because the selection is changing, object:state-changed:selected and/or object:selection-changed would be appropriate.

Actual results: There is no accessible event for the selection change. In addition, the To: entry emits object:state-changed:focused each time the selection changes.
Thanks Joanmarie. I assume you tested with version 24.x. Newer versions are using toolkit autocomplete. Can you test with beta from http://www.mozilla.org/en-US/thunderbird/channel/ and post  yoru results?
Flags: needinfo?(jdiggs)
Assuming the nightly I built three days ago is recent enough, this bug persists as described in the opening report.
Flags: needinfo?(jdiggs)
Joanie, is this still an issue nowadays?
Flags: needinfo?(jdiggs)

This appears to be fixed (at least in Thunderbird "Daily")

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(jdiggs)
You need to log in before you can comment on or make changes to this bug.