Closed Bug 1020380 Opened 7 years ago Closed 5 years ago

pdf viewer pdf.js -> font embedding issue, missing characters

Categories

(Firefox :: PDF Viewer, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 47

People

(Reporter: schnakomo, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7050)

Attachments

(2 files)

Attached image PDF_Firefox.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Please open the pdf-file from the following link as an example within pdf viewer from Firefox:

http://us.allianzgi.com/MarketingPrograms/External%20Documents/Allianz_NFJ_Dividend_Value_Fund_Fact_Sheet.pdf


Actual results:

The pdf-file is completely unreadable. All characters are wrong. The embedded fonts seem to be a problem for the Firefox PDF viewer (see attached screenshot: PDF_Firefox.jpg)


Expected results:

If you open the pdf-file from the link e.g. in Adobe Reader all characters appear correct (see attached screenshot: PDF_Adobe_Reader.jpg)
Attached image PDF_Adobe_Reader.jpg
Component: Untriaged → PDF Viewer
OS: Windows 7 → All
Hardware: x86_64 → All
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140607060136 CSet: cd4218cd70f9

"PDF 913050263cc666a84344892fb2f897 [1.4 Actuate PDF Writer (Low Resolution) 2.1 / Actuate e.Reports] (PDF.js: 1.0.302)"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7050
Depends on: 1253498
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Duplicate of this bug: 926080
You need to log in before you can comment on or make changes to this bug.