The next/previous buttons on the FTU screen don't change direction when choosing an RTL locale

RESOLVED DUPLICATE of bug 1037755

Status

Firefox OS
Gaia::First Time Experience
RESOLVED DUPLICATE of bug 1037755
4 years ago
3 years ago

People

(Reporter: Away for a while, Assigned: ivanovpavel)

Tracking

(Blocks: 1 bug)

unspecified
x86
Mac OS X
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Selecting Arabic on the FTU screen makes the list of languages change directions, but the next/previous buttons at the bottom of the screen don't change their direction.
Assignee: nobody → pivanov
There is some problem with webcomponents and we can't overide the css rules of them with `html[dir="rtl"]` ... I ping Vivien in Bug 992249 to see if he knows something

Comment 2

3 years ago
Pavel, that's OK. I think that we are not yet sure if this is something we want to do. Let's just get an assessment of this work and decide if it is something we should or should not do. Thanks!
The problem here is not related with this Bug only but is related with web components at all

Simple Case:
if we have `text-align: left` somewhere in a web component we can't override this style and this will be a problem for RTL support.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1037755
Mass Edit: adding the [rtl-meta]
Whiteboard: [rtl-meta]
QA Whiteboard: [rtl-impact]
Whiteboard: [rtl-meta]
Blocks: 1101112
No longer blocks: 906270
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15449/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.