Update Mozilla 32 to use NSS 3.16.2 (once it's ready)

RESOLVED FIXED in Firefox 31

Status

()

defect
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: wtc, Assigned: wtc)

Tracking

unspecified
mozilla33
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30 wontfix, firefox31+ fixed, firefox32+ fixed, firefox33 fixed, firefox-esr2431+ fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 1 obsolete attachment)

This bug is used for landing NSS 3.16.2 Beta and RTM tags in
mozilla-inbound and mozilla-central.
Pushed NSS_3_16_2_BETA3 to mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8406a2b981c5
I had to revert the NSS_3_16_2_BETA3 update because it broke the build
on some platforms. See bug 1020776.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e9859d8b5e51
Pushed NSS_3_16_2_BETA3 to mozilla-inbound, with a forced clobber:
https://hg.mozilla.org/integration/mozilla-inbound/rev/189492a9a115
Fixed the mochitest test_WebCrypto.html failures in bug 1021102.

Pushed NSS_3_16_2_BETA4 to mozilla-inbound, with a forced clobber:
https://hg.mozilla.org/integration/mozilla-inbound/rev/957b31f09f9e
I generated this patch with:
python client.py update_nss NSS_3_16_2_BETA4
Attachment #8444741 - Flags: review?(wtc)
Duplicate of this bug: 1029546
Comment on attachment 8444741 [details] [diff] [review]
update mozilla-aurora to NSS 3.16.2 beta 4

David, we usually don't attach the automatically diffs between NSS version as a patch, it's too big to review anyway.

In the past I usually attached a small text file that contained the command that I executed (the python command you stated), and IMHO that's sufficient.
Attachment #8444741 - Flags: review?(wtc) → review+
Summary: Update Mozilla 32 to use NSS 3.16.2 → Update Mozilla 32 to use NSS 3.16.2 (once it's ready)
This is a mandatory update for the current Mozilla Aurora 32 branch,
because it's currently using a beta version of NSS.

We must update the NSS version used by the Aurora 32 branch to a final release version of NSS.

I expected NSS 3.16.2 to be released in a few days.
Comment on attachment 8444741 [details] [diff] [review]
update mozilla-aurora to NSS 3.16.2 beta 4

FYI, by NOT attaching the patch, you encourage everyone to re-run the script for branch updates. That's recommended (instead of applying the patch). One reason is that it will correctly adjust the dummy-dependency-header files (which might differ between branches).
Blocks: 1029561
(In reply to Kai Engert (:kaie) from comment #9)
> Comment on attachment 8444741 [details] [diff] [review]
> update mozilla-aurora to NSS 3.16.2 beta 4
> 
> David, we usually don't attach the automatically diffs between NSS version
> as a patch, it's too big to review anyway.
> 
> In the past I usually attached a small text file that contained the command
> that I executed (the python command you stated), and IMHO that's sufficient.

Thanks, Kai - I'll do this in the future.
Comment on attachment 8444741 [details] [diff] [review]
update mozilla-aurora to NSS 3.16.2 beta 4

[Approval Request Comment]
Bug caused by (feature/regressing bug #): NSS update
User impact if declined: various bugs in NSS
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none

Note to whoever checks this in: this might require a clobber.
Attachment #8444741 - Flags: approval-mozilla-aurora?
Comment on attachment 8444741 [details] [diff] [review]
update mozilla-aurora to NSS 3.16.2 beta 4

Review of attachment 8444741 [details] [diff] [review]:
-----------------------------------------------------------------

r=wtc.
Attachment #8444741 - Flags: review+
The final release of NSS 3.16.2 has been tagged (which means you could skip the step of updating aurora to beta 4, and rather go directly to RTM).

The HG tag is NSS_3_16_2_RTM. (Source archives will be uploaded early tomorrow)
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8445500 - Flags: review?(wtc)
Attachment #8445500 - Flags: approval-mozilla-aurora?
Comment on attachment 8444741 [details] [diff] [review]
update mozilla-aurora to NSS 3.16.2 beta 4

Sounds like a plan.
Attachment #8444741 - Flags: approval-mozilla-aurora?
Comment on attachment 8445500 [details]
update mozilla-central and aurora 32 to NSS 3.16.2 RTM

r=wtc.
Attachment #8445500 - Flags: review?(wtc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a77c7952a36a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: leave-open
Resolution: --- → FIXED
Please don't resolve bugs unless they've been merged to m-c (per longstanding policy).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/a77c7952a36a
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
Whoops, Aurora is going to need the patch from bug 1021102 as well.
Comment on attachment 8445500 [details]
update mozilla-central and aurora 32 to NSS 3.16.2 RTM

OK, so the runs from comment 22 are green with the exception of comment 23, which I've confirmed is indeed fixed by additionally backporting the test fix from bug 1021102.
Attachment #8445500 - Flags: approval-mozilla-esr24?
Attachment #8445500 - Flags: approval-mozilla-beta?
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #24)
> OK, so the runs from comment 22 are green with the exception of comment 23,
> which I've confirmed is indeed fixed by additionally backporting the test
> fix from bug 1021102.

I assume you're referring to attachment 8439528 [details] [diff] [review] only, which patches dom/crypto/test, because the other patches in bug 1021102 should already be part of the NSS release.
Correct, just the test fix :-)
I'm pretty sure we're supposed to set ESR tracking to a specific release or the release management team gets annoyed.
Attachment #8445500 - Flags: approval-mozilla-esr24?
Attachment #8445500 - Flags: approval-mozilla-esr24+
Attachment #8445500 - Flags: approval-mozilla-beta?
Attachment #8445500 - Flags: approval-mozilla-beta+
Attachment #8445500 - Flags: approval-mozilla-aurora?
Attachment #8445500 - Flags: approval-mozilla-aurora+
Whiteboard: [qa-]
Depends on: 1049435
You need to log in before you can comment on or make changes to this bug.