Closed Bug 1020722 Opened 6 years ago Closed 6 years ago

[Vertical] Download retries from the home screen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(feature-b2g:2.0, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
feature-b2g 2.0
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jlal, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

User Story

+++ This bug was initially created as a clone of Bug #1020475 +++

Currently in the horizontal homescreen we display a default icon with a spinner over the top of it as an app is being installed. We should have this for the vertical homescreen as well.

Attachments

(3 files)

The current homescreen has functionality which will allow you to continue an app download (by tapping it) if it fails for some reason this should be ported over to the vertical home screen.
QA Whiteboard: [VH-FL-blocking+]
Assignee: nobody → jlal
Depends on: 1022094
blocking-b2g: --- → 2.0+
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S3 (6june)
blocking-b2g: 2.0+ → ---
feature-b2g: --- → 2.0
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
QA Whiteboard: [VH-FL-blocking+] → [VH-FL-blocking+][VH-FC-blocking+]
We traded bugs a few times! The cancel patch also has retry so changing assignments https://bugzilla.mozilla.org/show_bug.cgi?id=1022390
Assignee: jlal → crdlc
Attaching spec that includes the app installation states in a bit more detail. Let me know if there are any questions.
Marked as 2.0? blocker as it's a regression from 1.4.
blocking-b2g: --- → 2.0?
Removed 2.0? blocker since already flagged as feature-b2g 2.0.
blocking-b2g: 2.0? → ---
This visual asset package contains the correct spinner graphic.  Previous one is too small, not made for the new homescreen.
The functionality was resolved here: https://bugzilla.mozilla.org/show_bug.cgi?id=1022390 and visual refresh will be tracked here: https://bugzilla.mozilla.org/show_bug.cgi?id=1023950

Updating the design is high priority (for me if nothing else) this is simply to reflect the work that has landed.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Marking as fixed 2.0, 2.1 as this has been fixed in both branches.
Verified on master.
Status: RESOLVED → VERIFIED
blocking-b2g: --- → 2.0?
blocking-b2g: 2.0? → ---
Flags: in-moztrap?(jlorenzo)
Attached video Verify_Video_Flame.MP4
This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/10

Flame v2.0 version:
Gaia-Rev        ead3b72a84512750bc5faff4e9e8faa1715c0d05
Gecko-Rev       c715df57d1d1593ede48140ebc88e101f8c3f7da
Build-ID        20141208050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2

Flame v2.1 version:
Gaia-Rev        38e17b0219cbc50a4ad6f51101898f89e513a552
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8b92c4b8f59a
Build-ID        20141205001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141205.035305
FW-Date         Fri Dec  5 03:53:16 EST 2014
Bootloader      L1TC00011880
Flags: in-moztrap?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.