Closed Bug 1020758 Opened 5 years ago Closed 5 years ago

[Network Information API] Disable the API on Desktop

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox31 + fixed
firefox32 --- fixed

People

(Reporter: johnshih.bugs, Assigned: johnshih.bugs)

References

Details

(Whiteboard: [qa-] )

Attachments

(1 file)

As the API becomes one of standard web API, it needs to be supported on Desktop version as well (which only available on B2G and Fennec).
According to https://bugzilla.mozilla.org/show_bug.cgi?id=960426#c77, we should disable the API on desktop version instead.
Summary: [Network Information API] Support API for Desktop → [Network Information API] Disable the API on Desktop
John: Note that this goes into beta on Monday.

For release drivers: The risk here is that we're accidentally exposing an API which isn't working properly. If we end up releasing as-is, developers will likely have to UA-detect Firefox 31 and ignore the implementation there, rather than being able to simply test if the API is available.
I've tested locally and it worked.
Attachment #8435659 - Flags: review?(jonas)
try result: https://tbpl.mozilla.org/?tree=Try&rev=13688cfa7db8 (still running)
Comment on attachment 8435659 [details] [diff] [review]
Bug 1020758 - Disable Network Information on Desktop.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 960426
User impact if declined: We'll expose a non-functioning API to web developers. They will have to do UA-detection to filter out Firefox 33 any time they try to use this API.
Testing completed (on m-c, etc.): I'll leave this to John to answer, but given that this just disables a feature, very little testing is needed.
Risk to taking this patch: Very low. This uses existing infrastructure to disable a feature that has so far never been exposed to the web.
String or IDL/UUID changes made by this patch: None
Attachment #8435659 - Flags: review?(jonas)
Attachment #8435659 - Flags: review+
Attachment #8435659 - Flags: approval-mozilla-aurora?
Attachment #8435659 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #6)
> https://hg.mozilla.org/integration/b2g-inbound/rev/2e0533956466
> 
> Will land this on Aurora once it sticks on b-i.

I guess I don't need to ask for check-in needed, right?
(In reply to John Shih from comment #7)
> I guess I don't need to ask for check-in needed, right?

A pretty safe guess :)

https://hg.mozilla.org/releases/mozilla-aurora/rev/6f239dea3a36
https://hg.mozilla.org/mozilla-central/rev/2e0533956466
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Thanks for moving so quickly on this everyone!
Whoa this was all taken care of before I could catch up with my bugmail!  \o/  Thanks a lot.
Whiteboard: [qa-]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.