Add the ability to remove a device from the Sync account

RESOLVED DUPLICATE of bug 620706

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 620706
4 years ago
4 years ago

People

(Reporter: jaws, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

From http://www.reddit.com/r/firefox/comments/27bmgj/deleting_synced_devices_remotely/:

> I was wondering if there were a way to see what devices were currently
> syncing to your account, and if so, if you could remove them remotely
> (i.e. not from the device itself).

> I know you could change the password, which would disable all devices until 
> you log in again, but that seems like a more tedious route to take.
I suspect there is already a bug on file for this - hopefully rnewman can find it.  Also note that devices will be "dropped" after 21 days without it syncing.

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 821532

Updated

4 years ago
Duplicate of bug: 620706
(In reply to [:markh away until August 18] Mark Hammond from comment #1)
> I suspect there is already a bug on file for this - hopefully rnewman can
> find it.  Also note that devices will be "dropped" after 21 days without it
> syncing.

What does dropped imply

The device stops attempting to sync ?
The device is no longer registered and data is lost ?
Something else ?

Is there documentation on this **"dropped" after 21 days** feature somewhere, such as MDN ?
(In reply to John Hesling [:John99] from comment #4)

> What does dropped imply
> 
> The device stops attempting to sync ?
> The device is no longer registered and data is lost ?
> Something else ?

If a device is offline for a long period of time, it won't reupload its client record.

If the client record isn't reuploaded, the server will expire it, and other clients won't see that client in their lists.

If the device comes back (which it won't if you disconnected it from the account), it'll upload its client record again, and will "reappear".

Sync is like a shared whiteboard; participation is equivalent to membership.


> Is there documentation on this **"dropped" after 21 days** feature
> somewhere, such as MDN ?

http://docs.services.mozilla.com/storage/apis-1.5.html#concepts

briefly covers TTL.
You need to log in before you can comment on or make changes to this bug.