[Settings] Enter 10 times invalid PUK code, nothing shown, signal bar looks like searching for network

VERIFIED FIXED in 2.0 S5 (4july)

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: echang, Assigned: eragonj)

Tracking

unspecified
2.0 S5 (4july)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected)

Details

(Whiteboard: [2.0-flame-test-run-1][p=2])

Attachments

(7 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
Created attachment 8434701 [details]
PUK_1020769.log

### STR (Moztrap #2650)
1. Have a SIM pin locked card, requiring PUK. 
2. Sim Manager -> Sim Security -> turn on/off pin
3. PUK page shown.
4. Enter 10 times of incorrect PUK.
5. "No SIM Card Found" Not shown, signal bar is searching for network.
6. See https://www.youtube.com/watch?v=xaIDlFSI1vI

### Version of Flame
Gaia      a38a6a5c6fabc97dd16d5360632b5ac5c7e06241
Gecko     https://hg.mozilla.org/mozilla-central/rev/951e3a671279
BuildID   20140604160202
Version   32.0a1
(Reporter)

Updated

4 years ago
Summary: [Settings] Enter 10th invalid Pcode. → [Settings] Enter 10 times invalid PUK code, nothing shown, signal bar looks like searching for network
(Reporter)

Comment 2

4 years ago
QC ril: v10G-2
(Reporter)

Updated

4 years ago
See Also: → bug 838510, bug 833029
When this reproduces, does the network ever get successfully connected? If it does, then this is a big problem. If it doesn't, then this is a bug, but probably not a critical issue.
Flags: needinfo?(echang)
(Reporter)

Comment 4

4 years ago
It tries to connect for 10 minutes so far.. and keeps going.
Flags: needinfo?(echang)
(Reporter)

Comment 5

4 years ago
Created attachment 8445690 [details]
flame-v1.4.log

Same with flame v1.4
(Reporter)

Comment 6

4 years ago
Created attachment 8445691 [details]
buri-v1.4.log

Same with Buri v1.4

Updated

4 years ago
Attachment #8445691 - Attachment mime type: text/x-log → text/plain
(Reporter)

Updated

4 years ago
See Also: → bug 1006324
(Reporter)

Comment 7

4 years ago
Created attachment 8445717 [details]
Page 44 of [SPEC] DSDS v0.8 .png

The sim1 on status bar should look like no sim in it according to UX spec
Page 44 of [SPEC] DSDS v0.8 .PDF 
https://bugzilla.mozilla.org/attachment.cgi?id=8358418
(Reporter)

Comment 8

4 years ago
Created attachment 8445718 [details]
SignalSearching.png

Hi, EJ, Could you help to take a look at this? Thank you.

From log(Hsinyi)
cardstate == permanentBlocked
modem reports network state == searching
Which are both correct..
Flags: needinfo?(ejchen)
(Reporter)

Updated

4 years ago
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
Based on our offline discussion, let's wait for Gecko's response about the behavior under background. 

Because for Gaia, we only reflect the coming status on UI and do nothing else. Maybe Gecko has to change the status at the moment (instead of searching)!
Flags: needinfo?(ejchen)
(Reporter)

Comment 10

4 years ago
Hi, Hsinyi, Could you comment on this, thank you.
Flags: needinfo?(htsai)
Based on offline discussions with Eric and Hsinyi, I can investigate this bug first !
Assignee: nobody → ejchen
Seems that Gaia is displaying the UI for the permanent blocked card based on the network "searching" state.
This is not enough and not exactly correct. For example, even if gecko reports 'notSearching' state, it doesn't necessarily mean the card is permanent blocked. So I think the right way for this specific case is to check if card state is 'permanentBlocked'. 

Thank you, EJ!
Flags: needinfo?(htsai)
(Reporter)

Comment 13

4 years ago
Created attachment 8446455 [details]
tarako-v1.3t.log

A log from Tarako, the SIM PIN UI greys out and prevents me from changing PIN, signal bar not searching but it has a red X on it(v1.3t)(v2.0 spec should looks like no sim card in slot https://bug1020769.bugzilla.mozilla.org/attachment.cgi?id=8445717)
Created attachment 8446939 [details] [review]
patch on master

Hi Alive,

I made a small change in simslot because in this scenario, `permanentBlocked` means absent. In this way, I think it would be better to fix simslot instead of statsbar. 

Hope this patch makes sense to you can please help me review it when you have time  ! Any feedback or comment would be appreciated by the way.
Attachment #8446939 - Flags: review?(alive)
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1][p=2]
Target Milestone: --- → 2.0 S5 (4july)
Comment on attachment 8446939 [details] [review]
patch on master

r=me
Attachment #8446939 - Flags: review?(alive) → review+
Thanks all, merged into Gaia/master: 7361703667656942e22845496dfd308cafac1a59
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

4 years ago
Verified okay with this build.
Flame - aurora - v2.0 
Gaia      e935f4ff190b76c70d9b2af8856c542a6e4a7546
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/3f9d7a3a0b7b
BuildID   20140707160206
Version   32.0a2
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.