Closed Bug 1020792 Opened 6 years ago Closed 6 years ago

[Flame][V1.4][Music]The music can't be played automatically after stop recording video.

Categories

(Firefox OS Graveyard :: AudioChannel, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3T affected, b2g-v1.4 affected)

RESOLVED DUPLICATE of bug 1018825
Tracking Status
b2g-v1.3T --- affected
b2g-v1.4 --- affected

People

(Reporter: panda67231, Unassigned)

References

Details

(Whiteboard: bamboo)

Attachments

(3 files)

Attached video Music.mp4
[1.Description]:
Play music in background, then record a video, the music can't be played automatically. 

Attach the video:[Music.mp4]
Attach the logs: [bugreport_music.txt & logcat_music.txt]
Happened time:10:05PM

[2.Testing Steps]: 
1. Launch music and play a song.
2. Press home and launch camera to record a video.
3. Stop record and exit camera.


[3.Expected Result]: 
3. The music should be played immediately after stop recording video.

[4.Actual Result]: 
3. The music does not continue playing, but it keeps playing status, tap "Music" app icon, the songs be played immediately.  
Notes: Please hear the voice about attachment Music.mp4

[5.Reproduction build]: 
Gaia        7709936aeb21859d1607dbd038489493803bb085
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/5bf038fae0f1
BuildID    20140522160202
Version    30.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached file bugreport_music.txt
Attached file logcat_music.txt
It might be an expected behaviour but confused by the play indicator in the status bar, music did interrupted by recoding the video, but there is no audio-channel-changed event so the play indicator kept.
Component: Gaia::Music → AudioChannel
Duplicate of this bug: 1020689
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1018825
You need to log in before you can comment on or make changes to this bug.