Closed Bug 1020956 Opened 7 years ago Closed 6 years ago

[Flame][RTSP][V2.0] The kernel crash happened if RTSP streaming is interrupted several times by incoming call

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(b2g-v2.0 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: whsu, Assigned: ethan, NeedInfo)

Details

(Keywords: crash, Whiteboard: [b2g-crash][POVB])

Attachments

(3 files)

* Description:
  This problem happened on v2.0 build.
  If a RTSP streaming is interrupted several times by incoming call, it will cause a kernel crash.
  Attaching the demo video and log
  - Video: https://www.youtube.com/watch?v=usBWdbxq7xU&feature=youtu.be
  - Log: RTSP_Kernel_Crash_20140605.log

* Reproduction steps:
  1. Launch the following web page via browser
     - http://goo.gl/lE2eE3
  2. Tap the "Video test page"
  3. Making a phone call to the test device to  interrupt RTSP streaming
  4. Answering the phone call, then hang up phone after 20~30 seconds
  5. Repeat Step 3 and Step 4 several times

* Expected result:
  RTSP streaming still can be played

* Actual result:
  A kernel crash happened

* Build information: (V2.0 - Flame)
  - Gaia      a38a6a5c6fabc97dd16d5360632b5ac5c7e06241
  - Gecko     https://hg.mozilla.org/mozilla-central/rev/951e3a671279
  - BuildID   20140604160202
  - Version   32.0a1
blocking-b2g: --- → 2.0?
Two things:

1. Can we get a crash report URL for this?
2. Does this happen on 1.4?
Severity: normal → critical
Keywords: crash, qawanted
Whiteboard: [b2g-crash]
(In reply to Jason Smith [:jsmith] from comment #1)
> Two things:
> 
> 1. Can we get a crash report URL for this?
> 2. Does this happen on 1.4?

Actually for [2] - this won't reproduce on 1.4, since we don't support video RTSP on 1.4.
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Jason Smith [:jsmith] from comment #1)
> > Two things:
> > 
> > 1. Can we get a crash report URL for this?
> > 2. Does this happen on 1.4?
> 
> Actually for [2] - this won't reproduce on 1.4, since we don't support video
> RTSP on 1.4.

You got that right! :)
Thanks!
(In reply to Jason Smith [:jsmith] from comment #1)
> Two things:
> 
> 1. Can we get a crash report URL for this?
=> If this issue happens, I can't do anything.
   Device is disconnected and adb cannot work.
   I only can remove the battery and restart the device.
   Also, after restarting the device, there is nothing on "Crash Report" folder.
   Thanks.
Hi, all,

>   Attaching the demo video and log
>   - Video: https://www.youtube.com/watch?v=usBWdbxq7xU&feature=youtu.be
    Seeking to 3:28, you will see the bug.
Oh! I had never tested RTSP streaming with phone call interruptions.
Since the consequence of this bug is obviously critical, I will take it as my priority.
Assignee: nobody → ettseng
(In reply to Ethan Tseng [:ethan] from comment #6)
> Oh! I had never tested RTSP streaming with phone call interruptions.
> Since the consequence of this bug is obviously critical, I will take it as
> my priority.

Thanks for the help!
If there is anything I can do to help, please feel free to contact me. :)
Keywords: qawanted
blocking-b2g: 2.0? → 2.0+
I could also reproduce this bug, but the reproduction rate is not high (hit twice in several dozens of trials).

As discussed with Viral offline, when the bug happens, the Flame phone enters the so-called "download mode". The phone's screen is blankly white without any response (3'36" in William's video).
https://www.youtube.com/watch?v=usBWdbxq7xU&feature=youtu.be

Viral says there's nothing we can do with it since this situation cannot be resulted from Gaia/Gecko.
It looks like we need some external assistance.

Viral, would you like to add any input about this?
Flags: needinfo?(vwang)
BTW, we can see the following error message appears continuously (and quickly):
E/OMX-VDEC-1080P(  281): Error: Insufficient size allocated for extra-data

Bug 1020980 was filed to track this issue.
This error message looks suspicious but I am not sure whether it is relevant to this bug.
Hi Francis,

Device enter download mode (white screen as we met before) and we can't provide useful log for analysis.
We need partner's help for this bug.

reproduce step in https://bugzilla.mozilla.org/show_bug.cgi?id=1020956#c0
We can't try this on v1.3 since we didn't enable the function in v1.3 and only enable in master branch.
Flags: needinfo?(vwang) → needinfo?(frlee)
hi Yanan,

please refer to comment 10. we need your special help to capture some logs for further investigation, although we fully aware that this is not related to shipped version. please kindly let me know if you can help or you can share some tips/tool so that Moz RD can capture useful logs.

thank you very much
Flags: needinfo?(frlee) → needinfo?(yanan.zhao)
Updated STR.

1. Open the homepage on my own PC (only accessible inside LAN) using B2G browser.
   http://10.247.24.86/
   or
   http://ethan.corp.tpe1.mozilla.com/
2. Click the first link (codec details are described below).
   Video - 3GP-144p - Playing this video causes kernel panic on Flame!!
3. Wait for a few seconds, then the screen will be totally blank.

Note:
a) I can always reproduce this bug by clicking this link.
b) STR doesn't include any phone call interruptions.
c) This link is only accessible inside Mozilla's LAN.
d) Container format: 3GP
   Codec details:
   Video
     Codec: MPEG-4 Video (mp4v)
     Resolution: 176x144
     Frame rate: 12
     Decoded format: Planar 4:2:0 YUV
   Audio
     Codec: MPEG AAC Audio (mp4a)
     Channels: Stereo
     Sample rate: 44100 Hz
Please note in my STR in comment 12, phone call interruption is not a necessary step.
Additionally, this bug cannot be reproduced on Unagi and Buri. It's only on Flame.
The output of adb logcat according to my STR.
Good Job, Ethan! (+1 like!)
I also can always reproduce this bug by the steps you mentioned. :)
Dears,

    how about cat /proc/kmsg and logcat info until issue reproduce, is there anything useful?

@Viral,

    you said system enter download mode, if is sahara mode, can you try to use QPST capture the crash log.
Flags: needinfo?(yanan.zhao)
Attached file flame_proc_kmsg.log
The output of /proc/kmsg according to the STR.
(In reply to youlong.jiang from comment #17)
> Dears,
>     how about cat /proc/kmsg and logcat info until issue reproduce, is there
> anything useful?

Both the output of logcat and /proc/kmsg were attached.
adb logcat: attachment 8437581 [details]
/proc/kmsg: attachment 8438366 [details]

However, I didn't see error messages printed in these outputs at the moment the phone is bricked.
I am not sure these logs are helpful for analysis.
Francis, it is a kernel issue, please ask T2M to check this bug.
Component: RTSP → Vendcom
Flags: needinfo?(frlee)
hi Youlong,

may you please update your finding based on the logs attached on comment 19?
Flags: needinfo?(frlee) → needinfo?(youlong.jiang)
Clearing blocking flag for being a vendor bug.
blocking-b2g: 2.0+ → ---
Whiteboard: [b2g-crash] → [b2g-crash][POVB]
Summary: [RTSP][V2.0] The kernel crash happened if RTSP streaming is interrupted several times by incoming call → [Flame][RTSP][V2.0] The kernel crash happened if RTSP streaming is interrupted several times by incoming call
I revisited this bug from the latest B2G 2.1 build. This bug disappears on my Flame.

William, could you help to verify this bug was resolved already?
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(whsu)
Resolution: --- → WORKSFORME
Weird. I also cannot reproduce it on latest v2.1 build.
Thanks.

* Build information:
 - Gaia      c72257b2d27135bfcd68e89dd584182797784016
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/616e6924cb0b
 - BuildID   20140724160202
 - Version   34.0a1
Flags: needinfo?(whsu)
You need to log in before you can comment on or make changes to this bug.