The default bug view has changed. See this FAQ.

Schedule all Android 2.3 armv6 tests, except mochitest-gl, on all trunk trees and make them ride the trains

RESOLVED DUPLICATE of bug 1024091

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1024091
3 years ago
3 years ago

People

(Reporter: gbrown, Assigned: kmoir)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
With the exception of mochitest-gl, all tests run fine on Android 2.3 armv6 ("Android 2.2 Armv6 Opt" on Ash) and meet the requirements on https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy:

https://tbpl.mozilla.org/?tree=Ash&jobname=Android.*Armv6*

Let's get them running on trunk trees!

(mochitest-gl fails consistently on armv6. These tests do not run on Tegras, so getting them running on 2.3 armv6 would be a "bonus" -- I don't want to hold up the
other tests for mochitest-gl.)
(Assignee)

Updated

3 years ago
Assignee: nobody → kmoir
(Reporter)

Comment 1

3 years ago
(In reply to Geoff Brown [:gbrown] from comment #0)
> (mochitest-gl fails consistently on armv6. These tests do not run on Tegras,
> so getting them running on 2.3 armv6 would be a "bonus" -- I don't want to
> hold up the other tests for mochitest-gl.)

It turns out that mochitest-gl fails because webgl is intentionally disabled for armv6. See bug 950794 -- we should not attempt running mochitest-gl on armv6.
(Assignee)

Comment 2

3 years ago
Created attachment 8437048 [details] [diff] [review]
bug1020970-2.patch

Will attach builder diff too
Attachment #8437048 - Flags: review?(aki)
(Assignee)

Comment 3

3 years ago
Created attachment 8437049 [details]
bug1020970builder.diff

builder diff

Updated

3 years ago
Attachment #8437048 - Flags: review?(aki) → review+
(Assignee)

Updated

3 years ago
Attachment #8437048 - Flags: checked-in+
Live with reconfig on 2014-06-11 08:47 PT
(Assignee)

Comment 5

3 years ago
The good thing is that bug allowed us to move one more step toward getting rid of the tegras.  The bad news is that the Linux inhouse test pool has a high pending count right now.  Bug 1024091 suggests possible solutions to this problem.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

3 years ago
Going to revert due to capacity issues identified in bug 1024091
(Assignee)

Updated

3 years ago
Attachment #8437048 - Flags: checked-in+ → checked-in-
(Assignee)

Comment 7

3 years ago
Created attachment 8439483 [details] [diff] [review]
bug1020970name.patch

RyanVM suggested a better and less confusing name. Also tbpl friendly.
Attachment #8439483 - Flags: review?(aki)

Updated

3 years ago
Attachment #8439483 - Flags: review?(aki) → review+
(Assignee)

Updated

3 years ago
Attachment #8439483 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Depends on: 1024091

Comment 8

3 years ago
buildbot-config patch live in production :)
(Assignee)

Comment 9

3 years ago
This work is being done in bug 1024091
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1024091
You need to log in before you can comment on or make changes to this bug.