Closed Bug 1021174 Opened 6 years ago Closed 5 years ago

Intermittent test_bug495145.html,test_getIdentityAssertion.html | application crashed [@ CoreAudio + 0x1c7fe]

Categories

(Core :: Audio/Video, defect)

29 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed
firefox40 --- fixed
firefox-esr31 --- unaffected
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

(Keywords: crash, intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=41130491&tree=Mozilla-Inbound

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-1 on 2014-06-05 10:23:07 PDT for push 927b20a21b19
slave: t-snow-r4-0025

10:35:26     INFO -  4628 INFO TEST-START | /tests/content/media/test/test_bug495145.html
10:35:29     INFO -  TEST-INFO | Main app process: killed by SIGHUP
10:35:29  WARNING -  TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug495145.html | application terminated with exit code 1
10:35:29     INFO -  INFO | runtests.py | Application ran for: 0:10:47.159662
10:35:29     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/R8/R8ymrgSFF2GHd5xLWmb-Ik+++-k/-Tmp-/tmpWb8eBupidlog
10:35:29     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1401958094/firefox-32.0a1.en-US.mac.crashreporter-symbols.zip
10:36:10  WARNING -  PROCESS-CRASH | /tests/content/media/test/test_bug495145.html | application crashed [@ CoreAudio + 0x1c7fe]
10:36:10     INFO -  Crash dump filename: /var/folders/R8/R8ymrgSFF2GHd5xLWmb-Ik+++-k/-Tmp-/tmpFtZtct/minidumps/CB5EEDA1-566D-4CE3-B687-D93F1B05D016.dmp
10:36:10     INFO -  Operating system: Mac OS X
10:36:10     INFO -                    10.6.8 10K549
10:36:10     INFO -  CPU: amd64
10:36:10     INFO -       family 6 model 23 stepping 10
10:36:10     INFO -       2 CPUs
10:36:10     INFO -  Crash reason:  EXC_BAD_ACCESS / 0x0000000d
10:36:10     INFO -  Crash address: 0x0
10:36:10     INFO -  Thread 53 (crashed)
10:36:10     INFO -   0  CoreAudio + 0x1c7fe
10:36:10     INFO -      rbx = 0x000000011f979800   r12 = 0x000000011f979800
10:36:10     INFO -      r13 = 0x0000000000000000   r14 = 0x000000011c53fd00
10:36:10     INFO -      r15 = 0x000000011c64e2cc   rip = 0x00007fff8257e7fe
10:36:10     INFO -      rsp = 0x00000001239a3400   rbp = 0x00000001239a3400
10:36:10     INFO -      Found by: given as instruction pointer in context
10:36:10     INFO -   1  CoreAudio + 0x1c762

etc...

10:36:10     INFO -  25  CoreAudio + 0x2bd1e
10:36:10     INFO -      rip = 0x0000000155a2bd1f   rsp = 0x00000001239a3990
10:36:10     INFO -      rbp = 0x00000001239a39f0
10:36:10     INFO -      Found by: stack scanning
10:36:10     INFO -  26  XUL!void mozilla::AudioSegment::Resample<short>(SpeexResamplerState_*, unsigned int, unsigned int) [nsTArray.h:927b20a21b19 : 424 + 0x14]
10:36:10     INFO -      rip = 0x0000000102626ce0   rsp = 0x00000001239a39b0
10:36:10     INFO -      rbp = 0x00000001239a39f0
10:36:10     INFO -      Found by: stack scanning
10:36:10     INFO -  27  CoreAudio + 0x2b81a
10:36:10     INFO -      rbx = 0x00000001239a3a30   r12 = 0x646f626967737343
10:36:10     INFO -      r13 = 0x0000000102626ce0   r14 = 0x00000001239a3b48
10:36:10     INFO -      r15 = 0x000000011e24c508   rip = 0x0000000155a2b81b
10:36:10     INFO -      rsp = 0x00000001239a3a00   rbp = 0x00000001239a3a20
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  28  XUL!void mozilla::AudioSegment::Resample<short>(SpeexResamplerState_*, unsigned int, unsigned int) [nsTArray.h:927b20a21b19 : 424 + 0x14]
10:36:10     INFO -      rip = 0x0000000102626ce0   rsp = 0x00000001239a3a18
10:36:10     INFO -      rbp = 0x00000001239a3a20
10:36:10     INFO -      Found by: stack scanning
10:36:10     INFO -  29  AudioUnit + 0xc95
10:36:10     INFO -      rbx = 0x0000000155a2b81b   r12 = 0x000000011e24c500
10:36:10     INFO -      r13 = 0x646f626967737343   r14 = 0x0000000102626ce0
10:36:10     INFO -      r15 = 0x00000001239a3b48   rip = 0x00007fff830a8c96
10:36:10     INFO -      rsp = 0x00000001239a3a30   rbp = 0x00000001239a3a40
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  30  XUL!audiounit_stream_init [cubeb_audiounit.c:927b20a21b19 : 475 + 0x7]
10:36:10     INFO -      rip = 0x000000010314f3f4   rsp = 0x00000001239a3a50
10:36:10     INFO -      rbp = 0x00000001239a3b10
10:36:10     INFO -      Found by: stack scanning
10:36:10     INFO -  31  XUL!mozilla::AudioStream::OpenCubeb(cubeb_stream_params&, mozilla::AudioStream::LatencyRequest) [AudioStream.cpp:927b20a21b19 : 489 + 0x3b]
10:36:10     INFO -      rbx = 0x0000000000000064   r12 = 0x000000011db95840
10:36:10     INFO -      r13 = 0x0000000105787ad8   r14 = 0x00000001239a3ba0
10:36:10     INFO -      r15 = 0x00000001313e1650   rip = 0x0000000102616706
10:36:10     INFO -      rsp = 0x00000001239a3b20   rbp = 0x00000001239a3b80
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  32  XUL!mozilla::AudioStream::Init(int, int, mozilla::dom::AudioChannel, mozilla::AudioStream::LatencyRequest) [AudioStream.cpp:927b20a21b19 : 455 + 0xa]
10:36:10     INFO -      rbx = 0x0000000000000000   r12 = 0x0000000080004005
10:36:10     INFO -      r13 = 0x000000011db95840   r14 = 0x0000000000000000
10:36:10     INFO -      r15 = 0x0000000000000002   rip = 0x0000000102616502
10:36:10     INFO -      rsp = 0x00000001239a3b90   rbp = 0x00000001239a3c80
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  33  XUL!mozilla::MediaDecoderStateMachine::AudioLoop() [MediaDecoderStateMachine.cpp:927b20a21b19 : 789 + 0x13]
10:36:10     INFO -      rbx = 0x000000013119dc01   r12 = 0x0000000000000000
10:36:10     INFO -      r13 = 0x0000000000000000   r14 = 0x000000011dc681e0
10:36:10     INFO -      r15 = 0x000000011db95840   rip = 0x000000010262ca3c
10:36:10     INFO -      rsp = 0x00000001239a3c90   rbp = 0x00000001239a3d10
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  34  XUL!nsRunnableMethodImpl<void (mozilla::MediaDecoderStateMachine::*)(), void, true>::Run() [nsThreadUtils.h:927b20a21b19 : 387 + 0x15]
10:36:10     INFO -      rbx = 0x000000011c65f5e0   r12 = 0x0000000000000000
10:36:10     INFO -      r13 = 0x000000000000ff00   r14 = 0x000000011c65f608
10:36:10     INFO -      r15 = 0x00000001239a3e07   rip = 0x00000001026484a6
10:36:10     INFO -      rsp = 0x00000001239a3d20   rbp = 0x00000001239a3d20
10:36:10     INFO -      Found by: call frame info
10:36:10     INFO -  35  XUL!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:927b20a21b19 : 766 + 0x5]
10:36:10     INFO -      rbx = 0x000000011c65f5e0   r12 = 0x0000000000000000
10:36:10     INFO -      r13 = 0x000000000000ff00   r14 = 0x000000011c65f608
10:36:10     INFO -      r15 = 0x00000001239a3e07   rip = 0x0000000101086134
10:36:10     INFO -      rsp = 0x00000001239a3d30   rbp = 0x00000001239a3df0
10:36:10     INFO -      Found by: call frame info
https://tbpl.mozilla.org/php/getParsedLog.php?id=41205518&tree=Try
Summary: Intermittent test_bug495145.html | application crashed [@ CoreAudio + 0x1c7fe] → Intermittent test_bug495145.html,test_getIdentityAssertion.html | application crashed [@ CoreAudio + 0x1c7fe]
See Also: → 847903
(In reply to TBPL Robot from comment #19)
https://tbpl.mozilla.org/php/getParsedLog.php?id=47745163&full=1&branch=mozilla-inbound#error1

It crashed at https://hg.mozilla.org/integration/mozilla-inbound/file/1284474ca9ac/media/libcubeb/src/cubeb_audiounit.c#l632.

I see many crashes in CoreAudio recently.

Hi Paul,
Do you have any idea about this crash?
Flags: needinfo?(paul)
Not sure. This is 10.6 only, and I thought it was caused by the MSG refactoring, but it predates it by months.

Maybe 16 streams in Matthew's patch in bug 847903 was not low enough, but that would make me sad.
Flags: needinfo?(paul)
No longer blocks: 1059265
https://hg.mozilla.org/mozilla-central/rev/f24b7fab8aa6

Going to go ahead and resolve this under the assumption that this will be the last we think of this until after 10.6 is shut off permanently.
Assignee: nobody → ryanvm
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.