Closed Bug 1059265 Opened 7 years ago Closed 7 years ago

Intermittent test_reactivate.html | application crashed [@ CoreAudio + 0x1c7fe]

Categories

(Core :: Audio/Video, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35
Tracking Status
firefox33 --- unaffected
firefox34 --- fixed
firefox35 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: cbook, Assigned: jwwang)

References

()

Details

(Keywords: crash, intermittent-failure)

Attachments

(1 file)

Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound debug test mochitest-1 on 2014-08-27 03:29:02 PDT for push e2eda589ea8d

slave: t-snow-r4-0124

https://tbpl.mozilla.org/php/getParsedLog.php?id=46849496&tree=Mozilla-Inbound



TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_reactivate.html | application terminated with exit code 1
PROCESS-CRASH | /tests/content/media/test/test_reactivate.html | application crashed [@ CoreAudio + 0x1c7fe]

04:04:58  WARNING -  PROCESS-CRASH | /tests/content/media/test/test_reactivate.html | application crashed [@ CoreAudio + 0x1c7fe]
04:04:58     INFO -  Crash dump filename: /var/folders/qD/qD47WTkVGj4hMGYM9+J8Nk+++-k/-Tmp-/tmpp7W_CJ.mozrunner/minidumps/4A99C972-C7F4-40C9-A479-3249ADFA304E.dmp
04:04:58     INFO -  Operating system: Mac OS X
04:04:58     INFO -                    10.6.8 10K549
04:04:58     INFO -  CPU: amd64
04:04:58     INFO -       family 6 model 23 stepping 10
04:04:58     INFO -       2 CPUs
04:04:58     INFO -  Crash reason:  EXC_BAD_ACCESS / 0x0000000d
04:04:58     INFO -  Crash address: 0x0
04:04:58     INFO -  Thread 70 (crashed)
04:04:58     INFO -   0  CoreAudio + 0x1c7fe
04:04:58     INFO -      rbx = 0x000000012be5b000   r12 = 0x000000012be5b000
04:04:58     INFO -      r13 = 0x0000000000000000   r14 = 0x0000000120747e00
04:04:58     INFO -      r15 = 0x000000012b4b295c   rip = 0x00007fff83d6f7fe
04:04:58     INFO -      rsp = 0x0000000108ad8370   rbp = 0x0000000108ad8370
04:04:58     INFO -      Found by: given as instruction pointer in context
04:04:58     INFO -   1  CoreAudio + 0x1c762
04:04:58     INFO -      rip = 0x00007fff83d6f763   rsp = 0x0000000108ad8380
04:04:58     INFO -      rbp = 0x0000000108ad83c0
04:04:58     INFO -      Found by: stack scanning
04:04:58     INFO -   2  CoreAudio + 0x17b78
04:04:58     INFO -      rip = 0x00007fff83d6ab79   rsp = 0x0000000108ad83d0
04:04:58     INFO -      rbp = 0x0000000108ad8430
04:04:58     INFO -      Found by: stack scanning
04:04:58     INFO -   3  CoreAudio + 0x1b44b
04:04:58     INFO -      rip = 0x00007fff83d6e44c   rsp = 0x0000000108ad83e0
04:04:58     INFO -      rbp = 0x0000000108ad8430
04:04:58     INFO -      Found by: stack scanning
04:04:58     INFO -   4  CoreAudio + 0x1797f
04:04:58     INFO -      rip = 0x00007fff83d6a980   rsp = 0x0000000108ad8440
04:04:58     INFO -      rbp = 0x0000000108ad84b0
04:04:58     INFO -      Found by: stack scanning
04:04:58     INFO -   5  CoreAudio + 0x18298
04:04:58     INFO -      rip = 0x00007fff83d6b299   rsp = 0x0000000108ad8450
04:04:58     INFO -      rbp = 0x0000000108ad84b0
04:04:58     INFO -      Found by: stack scanning
04:04:58     INFO -   6  CoreAudio + 0x1770b
04:04:58     INFO -      rip = 0x00007fff83d6a70c   rsp = 0x0000000108ad84c0
04:04:58     INFO -      rbp = 0x0000000108ad8520
04:04:58     INFO -      Found by: stack scanning
There does not seem to be a Web Audio API failure, moving to Video/Audio.
Component: Web Audio → Video/Audio
Probably a problem in the new MacOX MP4 support?
Flags: needinfo?(giles)
Seems suspicious, but if so it's corruption from the failed dlopen("CoreMedia.framework").

The test is skipping the mp4 test files, as it should on 10.6. The crash is happening on actual audio output from other file types.

Kinetik, does this look familiar?

03:30:50     INFO -  95 INFO [983] WARNING: Couldn't load CoreMedia framework: file /builds/slave/m-in-osx64-d-00000000000000000/build/content/media/fmp4/apple/AppleCMLinker.cpp, line 48
...
04:04:58     INFO -  29  XUL!audiounit_stream_init [cubeb_audiounit.c:e2eda589ea8d : 632 + 0x7]
Flags: needinfo?(giles) → needinfo?(kinetik)
Not something I've seen before, although I think there are some random audiounit crashes filed for test failures floating around.  Nobody has had time to investigate.
Flags: needinfo?(kinetik)
FWIW I haven't been able to reproduce in about 8 tries with a local debug build on my 10.6 machine.
I'm assuming this is MSG fallout given the timing.
(In reply to Carsten Book [:Tomcat] from comment #0)

The stack trace is similar to bug 1021174 comment 20 and bug 847903 might be the cause. However, it doesn't make sense for AudioUnitInitialize() to crash silently instead of returning an error. Since this bug is hard to repro, I would like to modify the test case to reduce the number of concurrently running media elements (thus reducing the number of active cubeb streams). If it does fix the problem, then we might have to revisit bug 847903 again.

Hi Matthew,
Does that make sense to you?
Depends on: 1021174, 847903
Flags: needinfo?(kinetik)
Sure.
Flags: needinfo?(kinetik)
Depends on: 1067858
Reduce number of concurrent playback and active cubeb streams to avoid hitting bug 847903.

Try desktop: https://tbpl.mozilla.org/?tree=Try&rev=76052493625a
Try mobile: https://tbpl.mozilla.org/?tree=Try&rev=355803e2538b

No failures on test_reactivate.html.
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8490521 - Flags: review?(kinetik)
Just a notice that bug 1067858 (about audio channel) must be fixed first which will prevent media elements from resuming playback correctly in this test case.
Attachment #8490521 - Flags: review?(kinetik) → review+
Please check in bug 1067858 before this bug.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/bbf28ffae3d7
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
I think we need this on Aurora as well.
Flags: needinfo?(jwwang)
No longer depends on: 1021174
Flags: needinfo?(jwwang)
I will try to uplift bug 1067858 first, then this bug to Aurora.
Comment on attachment 8490521 [details] [diff] [review]
1059265_reduce_num_of_concurrent_playback-v1.patch

Approval Request Comment
[Feature/regressing bug #]:unknown
[User impact if declined]:test case failure will decrease our test coverage
[Describe test coverage new/current, TBPL]:
Try: https://tbpl.mozilla.org/?tree=Try&rev=45680735e952
[Risks and why]: Low. It has been exercised in Central for weeks.
[String/UUID change made/needed]:none
Attachment #8490521 - Flags: approval-mozilla-aurora?
Comment on attachment 8490521 [details] [diff] [review]
1059265_reduce_num_of_concurrent_playback-v1.patch

Aurora+
Attachment #8490521 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Hi Ryan, 

I see that this was fixed on FF 34. Is there anything further that is happening or needs to happen on this bug to move it along?
Flags: needinfo?(ryanvm)
Doesn't look like it. Bug's been fixed with no further activity for over 6 months now.
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.