Closed Bug 1021271 Opened 5 years ago Closed 5 years ago

Status Bar needs refinement for 1.5x Scale and New Homescreen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, feature-b2g:-, b2g-v2.0 fixed, b2g-v2.1 fixed)

RESOLVED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
feature-b2g -
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: padamczyk, Assigned: pivanov)

References

(Blocks 1 open bug)

Details

(Whiteboard: [systemsfe])

Attachments

(5 files)

The visual design on the status bar has regressed in v.2. Icons don't work anymore and the layout needs some love. Issues:
1. Notifications should be white, the blue icon clashes with the translucent status bar.
2. The time and notifications count font are too thick
3. The icons and fonts need to be horizontally aligned better, currently they are floating anchored to nothing, no baseline, no central horizon.
4. The "off" states of icons need to be more translucent. ie. When wifi is in its searching animation the "off" bars are very dark, which makes them look far too strong.



Not included in this bug, but blocking this bug:
* Notifications being cut off: https://bugzilla.mozilla.org/show_bug.cgi?id=1019216
* Time & AM/PM having a huge gap: https://bugzilla.mozilla.org/show_bug.cgi?id=1019200
BTW Fira font bug: https://bugzilla.mozilla.org/show_bug.cgi?id=987872
Assignee: nobody → epang
Depends on: Fira
Component: Gaia::Homescreen → Gaia::System
QA Whiteboard: [VH-FL-blocking-]
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking-]
With the reduced underlay certain colours (red and blue) clash with wallpapers. The entire set of status bar icons need to be reworked:
+ reduce the amount colours - get rid of the blue, make it white, can we remove more colours, like the charging yellow? 
+ need a better solution for errors, the bright red doesn't work anymore
+ the dark grey / black looks terrible in the "off" states, we need to add more transparency to those forms.
Can you please provide an ETA on this fix? Thanks!
Flags: needinfo?(epang)
Blocks: 1016987
Depends on: 1019216
(In reply to Patryk Adamczyk [:patryk] UX from comment #4)
> Can you please provide an ETA on this fix? Thanks!

Hi Patryk,
I'll look into this with Pavel today (and tomorrow if needed).  We should have a fix no later then by end of this week.

Thanks! 
Eric
Flags: needinfo?(epang)
If we're able to get these icons in, let's request approval. Moving to block bug 1017954 for now.
Blocks: vertical-home-next
No longer blocks: vertical-homescreen
Hey Pavel,

I've updated the sprites and put them on box here:
https://mozilla.box.com/s/jcx4vwaanew1q3kk7nap

Note: We talked about this before but 2.25x (madai) is different because there are only 4 signal bars instead of 5.  I've left 5 for all other sizes

Also, the existing sprite for 2x was extremely outdated - so there's a change that more css will need to be updated for it.

I've also created a spec you can follow:
https://mozilla.box.com/s/bq6hip8zqmuz0yqjc9l4

The spec covers alignment, spacing and font style/sizes.

Note I also updated the gap between the time and am/pm from the other bug we already fixed (I felt like the gap was still too big after looking at it again).


I believe the only assets left are the aPNGs.  I'm trying to figure out how to create them, so I'll add a link to this bug when they are ready :).


Thanks Pavel, if you have any questions about what I've attached so far let me know!
Assignee: epang → pivanov
Flags: needinfo?(pivanov)
Attached file patch for Gaia/master
Hey Eric,
can you test this patch ... I'm waiting my device ... and I'm not sure how it looks like on real device
Attachment #8439878 - Flags: ui-review?(epang)
Flags: needinfo?(pivanov)
Hi Stephany, I think this bug should be added to the 2.0 blocking list.  It will update colours, alignment, text, etc. of the status bar.  Let me know if you agree, thanks!
Flags: needinfo?(swilkes)
(In reply to Eric Pang [:epang] from comment #9)
> Hi Stephany, I think this bug should be added to the 2.0 blocking list.  It
> will update colours, alignment, text, etc. of the status bar.  Let me know
> if you agree, thanks!

Steph, just realized that this is already blocking vertical homescreen.  Thanks!
Flags: needinfo?(swilkes)
blocking-b2g: --- → 2.0?
feature-b2g: --- → -
blocking-b2g: 2.0? → 2.0+
Whiteboard: [systemsfe]
Blocks: vertical-homescreen
No longer blocks: vertical-home-next
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Blocks: 1015336
No longer blocks: vertical-homescreen
Whiteboard: [systemsfe]
Whiteboard: [systemsfe]
Attached file Status Bar Check.pdf
Hey Pavel,

The status bar is looking pretty good, but there's a few changes that still need to be made.  I've attached a pdf that covers the remaining changes that are needed.  Some of the items were updates to the sprites/apngs which I've done, so they just need to be replaced.  Let me know if you have any questions :).  Flag me for ui-review when ready so we can check the changes and fix anything else that might come up if needed.  Thanks!
Flags: needinfo?(pivanov)
Duplicate of this bug: 1029047
Target Milestone: --- → 2.0 S5 (4july)
Hey Eric,
as we talk few hours ago ... I fixed the issues based on your email :) and I think everything works now :)
PR is updated
Flags: needinfo?(pivanov)
Comment on attachment 8439878 [details] [review]
patch for Gaia/master

Lots of work and back and forth here!  Great work Pavel :)! R+
Attachment #8439878 - Flags: ui-review?(epang) → ui-review+
Attachment #8439878 - Flags: review?(21)
Comment on attachment 8439878 [details] [review]
patch for Gaia/master

r+ if you remove the change in apps/settings, which seems completely unrelated to this patch :)
Attachment #8439878 - Flags: review?(21) → review+
Thanks :) 

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/e0ce5d095b767af9b371d67e0f5d1bcc1a680099
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.