Closed Bug 1021278 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen]When the user tries to pinch inwards when already in 4 column view, editing mode is enabled

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 1021311
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: dharris, Unassigned)

References

()

Details

(Whiteboard: [2.0-flame-test-run-1])

Description:
The user either enters homescreen edit mode, or is taken to the 'change wallpaper' screen when pinching inwards again after already being in 4 column view mode, or pinching outwards when already being in 3 column view mode


Repro Steps:
1) Update a Flame to 20140605040202
2) From 3 column view on the Vertical Homescreen, Pinch inwards
3) Once the homescreen is in 4 column view, pinch inwards again


Actual:
If the user is pinching on top of apps, editing mode is enabled. If the user is pinching on top of empty space they are taken to the 'Change Wallpaper' screen


Expected:
Nothing happens when pinching inwards when the user is already in 4 column view

Environmental Variables:
Device: Flame 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) 
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 


Keywords: Four, Transition, Blink, Flash, Stutter, Homescreen Editing


Notes: This issue also occurs when trying to pinch outwards, when already in 3 column view


Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13012/
See attached: Logcat, Video - http://youtu.be/Mk8RmjEzEBc
This issue DOES occur on Open C 2.0


Open_C 2.0

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) 
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
This issue DOES occur on Buri 2.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140605040202
Gaia: d2cfef555dabab415085e548ed44c48a99be5c32
Gecko: 51b428be6213
Version: 32.0a1 (2.0) MOZ
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Blocks: 1015336
No longer blocks: vertical-homescreen
Hey, I think this was filed earlier today, and I would like to track it in bug 1021311 if that's alright.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021311
No longer blocks: 1015336
You need to log in before you can comment on or make changes to this bug.