Closed Bug 1021311 Opened 5 years ago Closed 5 years ago

[Homescreen] Sometimes when pinching the homescreen enters in edit mode instead of zooming in/out

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dmarcos, Assigned: crdlc)

References

Details

Attachments

(2 files)

Attached video pinchHomeScreen.MOV
When doing a pinch gesture if one of the fingers taps first an icon I enter in edit mode instead of zooming in/out (attached video to illustrate the problem, I try the gesture three times and the 3rd one ends up in edit mode)

Increasing the time to determine if a tap is a long tap might solve the problem
Hardware: PowerPC → ARM
I can reproduce this & it's annoying. This causes the icon that was accidentally pressed to fall out of alignment with the rest of the homescreen UI in a persistent fashion.
blocking-b2g: --- → 2.0?
Duplicate of this bug: 1021278
Blocks: 1015336
No longer blocks: vertical-homescreen
QA Whiteboard: [VH-FL-blocking-]
Blocking bug 1022414 due to the icon alignment issue. We should be able to recover from entering the zoom  dialog, or any other dialog.
Blocks: 1022414
No longer blocks: 1015336
I'm going to flag the blocking bug instead of this one to simplify tracking.
blocking-b2g: 2.0? → ---
Duplicate of this bug: 1022931
Duplicate of this bug: 1023122
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Github pull request
Attachment #8437680 - Flags: review?(kgrandon)
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Comment on attachment 8437680 [details]
Github pull request

I believe the root cause of this is problems with the dragdrop logic.

Additionally it turns out that we are removing this feature in bug 1023426. Sorry about that =/ Let's close this for now, but if we get everything done, we can look at bringing back the zoom feature if people complain and it's solid.
Attachment #8437680 - Flags: review?(kgrandon)
Being that we are removing this feature, going to mark as a wontfix for now. Please keep the bug blocking status though so it's easier to track down in the future if we need to.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
ok Kevin, that's life
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking+] → [VH-FL-blocking-][VH-FC-blocking-]
No longer blocks: 1022414
Hi, I'm on 2.0 latest build and pinching from three to four columns, or from four to three, simply do not work for me. Can you please tell me how to do it properly?
I'm following UX manual to pinch diagonally, but nothing happens, nor in edit nor in normal mode...
(In reply to Marek Raida from comment #11)
> Hi, I'm on 2.0 latest build and pinching from three to four columns, or from
> four to three, simply do not work for me. Can you please tell me how to do
> it properly?
> I'm following UX manual to pinch diagonally, but nothing happens, nor in
> edit nor in normal mode...

Hi, we've unfortunately had to disable this feature while we iterate more on the concept. For now you can go into settings and change the number of columns under the 'Homescreen' option. Hopefully we will bring this feature or something like it back in the future.
OK, thx for the explanation...
You need to log in before you can comment on or make changes to this bug.