[Homescreen] OTA update from horiz homescreen will not update to Vertical homescreen

VERIFIED FIXED in Firefox 32, Firefox OS v2.0

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: tchung, Assigned: gerard)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, firefox31 wontfix, firefox32 fixed, firefox33 fixed, b2g-v2.0 fixed, b2g-v2.1 fixed)

Details

(Whiteboard: [2.0-FL-bug-bash][systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8435364 [details]
screenshot of old homescreen after updating

Repro:
1) install 2.0 nightly and update to latest image with Vertical Homescreen enabled via OTA (6/4 build -> 6/5 build)

Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

2) restart phone after OTA update
3) verify the old homescreen is still present, not the new one


Expected:
- new vertical homescreen after OTA

Actual:
- old homescreen
(Reporter)

Updated

4 years ago
Whiteboard: [2.0-FL-bug-bash]
Obviously we need to block on this.
blocking-b2g: 2.0? → 2.0+
Whiteboard: [2.0-FL-bug-bash] → [2.0-FL-bug-bash][systemsfe]

Comment 2

4 years ago
I think after OTA, user should change it manually in settings > homescreen, isn't it?
I think we just need to bump the gecko settings version.

Updated

4 years ago
Duplicate of this bug: 1021743
Blocks: 989848

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking+]

Updated

4 years ago
QA Whiteboard: [VH-FL-blocking+] → [VH-FL-blocking-]
Created attachment 8437079 [details] [diff] [review]
0001-Bug-1021351-Update-settings-db-version-for-20.patch

I think this is mostly all we need to do for the setting? I think this is also probably necessary to upgrade edge gestures.
Attachment #8437079 - Flags: review?(anygregor)
Attachment #8437079 - Flags: review?(anygregor) → review+
Adding checkin-needed for: https://bug1021351.bugzilla.mozilla.org/attachment.cgi?id=8437079
Status: NEW → ASSIGNED
Keywords: checkin-needed
Target Milestone: --- → 2.0 S4 (20june)
Comment on attachment 8437079 [details] [diff] [review]
0001-Bug-1021351-Update-settings-db-version-for-20.patch

This is needed for the vertical homescreen.
[User impact] if declined: We can not ship the vertical homescreen.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): We can not ship the vertical homescreen.
[String changes made]: None.
Attachment #8437079 - Flags: approval-gaia-v2.0?
Comment on attachment 8437079 [details] [diff] [review]
0001-Bug-1021351-Update-settings-db-version-for-20.patch

Oops, maybe this is already blocking so it's not needed to ask for approval?
Attachment #8437079 - Flags: approval-gaia-v2.0?
(In reply to Kevin Grandon :kgrandon from comment #9)
> Comment on attachment 8437079 [details] [diff] [review]
> 0001-Bug-1021351-Update-settings-db-version-for-20.patch
> 
> Oops, maybe this is already blocking so it's not needed to ask for approval?

Right - only non-blocking features need approval. This gets auto-approval.
https://hg.mozilla.org/mozilla-central/rev/479767da77af
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
(Assignee)

Comment 12

4 years ago
Taking the bug: I think I got the issue again this morning after updating a device, so I'll make sure we are okay on this.
Assignee: kgrandon → lissyx+mozillians
Doh.. Thanks for taking this Alex. Ping me on IRC if there's anything I can help with.
https://hg.mozilla.org/releases/mozilla-aurora/rev/8d93866031c1
status-b2g-v2.0: affected → fixed
status-firefox31: --- → wontfix
status-firefox32: --- → fixed
status-firefox33: --- → fixed
(Assignee)

Comment 15

4 years ago
(In reply to Alexandre LISSY :gerard-majax from comment #12)
> Taking the bug: I think I got the issue again this morning after updating a
> device, so I'll make sure we are okay on this.

So far, updated my Peak which was running a 2.0 from early may to current master, vertical homescreen is started by default. Looks good to me, good work!
Verified by upgrading from mozilla-central-flame on 2014-04-17-04-02-06 to today's aurora. Vertical Homescreen is also started by default.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.