"Search or Enter Address" can be misinterpreted as a physical address

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Search
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Kate Glazko, Unassigned)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(b2g-v2.0 wontfix, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-FL-bug-bash] )

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
I tried to enter a street address, and didn't realize that it actually meant URL. Address might be misleading wording.

Updated

4 years ago
Whiteboard: [2.0-FL-bug-bash]
Need input from UX team.
Flags: needinfo?(firefoxos-ux-bugzilla)
Blocks: 946452

Comment 2

4 years ago
Flagging Rob. Also noted the same thing yesterday. Suggest "Search or enter web address" (which is ideal but will truncate in many languages" or "Search or enter URL" or a sort of combo "Search or enter website." Rob, what do you think? 

Jason, this will mean late-l10n I think.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)

Comment 3

4 years ago
Flagging Matej. Matej, the issue is that the default text in the Rocketbar (a search bar) is "Search or enter address." It's not at all clear that "address" in this case ONLY means "web address," so users have understandably been trying to enter street addresses as they might in a maps app.

We also have L10N considerations (i.e. we can't truncate default text here). 

My suggestion is clear and brief, if not ad-ready: "Search or Website".

We can't say "web search" because the device is also searched, and I'm not sure "web URL" translates well. Thoughts?
Flags: needinfo?(rmacdonald) → needinfo?(Mnovak)

Comment 4

4 years ago
Can you clarify where this appears (I'm not what Rocketbar refers to)? The reason I ask is that this is also our default string in Firefox for Android. If we're going to make a change, we should be consistent throughout and be sure to involve the relevant people from the Android UX team.
Flags: needinfo?(Mnovak)

Comment 5

4 years ago
Created attachment 8436154 [details]
2014-06-06-15-54-17.png

Screenshot attached. :)

Comment 6

4 years ago
(In reply to Stephany Wilkes from comment #5)
> Created attachment 8436154 [details]
> 2014-06-06-15-54-17.png
> 
> Screenshot attached. :)

Ah yes, I see. Thanks.

I'd actually recommend decoupling this from the Android string entirely. The really helpful feature is that you can find things on the Web as well as on your phone and the magnifying glass says "search" more than anything else. Given that, here's what I would recommend:

"Search phone or the Web"

(It feels more important to call out the phone searching functionality than the fact that a user can enter a URL.)

My backups to that would be "Search or enter URL" and "Search or enter website."

Related, what does it say in the browser on FxOS? If we only make a slight change, we should be consistent, but then we may want to look at the Android string as well.

Comment 7

4 years ago
Sorry, I meant "Search phone & the Web"
It says "Search or Enter Address" in the browser, For 2.0 the only local search available will be apps, so I dont think "Search phone" is appropriate

Comment 9

4 years ago
So. This string is everywhere: FF for Android, Desktop, etc. We'll leave it for 2.0 and re-evaluate for a later release. Thanks Matej!

Updated

4 years ago
No longer blocks: 946452
It would be cool if a street address was used and the Rocketbar launches some map app to locate that location!  Alas, that's a new feature.
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → affected
This matches our desktop experience, and since I haven't heard too many complaints about this, I think we should leave as-is for now. If we have a new string to use, or additional data points that say this is incorrect, then we can certainly reopen and investigate.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.