Usage bar in notification tray does not update state when SIM card is unlocked

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: vt, Assigned: mai)

Tracking

({regression})

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: [caf priority: p2][CR 674098][2.0-FL-bug-bash])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
# Build Information

Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140605040202
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

# Description

When there are two SIM cards that have SIM card lock and the phone is restarted, the usage bar in the notification tray says the SIM cards are locked when they are in fact unlocked.

# Steps to Reproduce

1) Add a SIM lock on both SIM cards
2) Restart phone
3) Unlock phone
4) Open notification tray, see locked SIM message
5) Close notification tray
6) Type in SIM unlock code for both SIMs
7) Open notification tray

# Expected Results

Usage bar graph displays in the notification tray.

# Actual Results

Displays a message saying SIM card is locked in place of the usage bar app.

# Other Notes

Requires multiple SIMs.
QA Wanted to see if this issue is reproducible on 1.4.
Keywords: qawanted

Updated

4 years ago
Component: Gaia → Gaia::System

Updated

4 years ago
Component: Gaia::System → Gaia::Cost Control
Created attachment 8436655 [details]
FlameV2.0BuriV2.0.jpg

Not happening on Buri v2.0.
Created attachment 8436704 [details]
empty

Sorry, ignore my previous comment, it aslo happens on my Buri.
Attachment #8436655 - Attachment is obsolete: true
QA Contact: ckreinbring
(Assignee)

Comment 4

4 years ago
Hi,
I can't reproduce it on my buri device with v2.0. Do you mind checking again?
Regards
Unable to repro on Flame 1.4, After unlocking both SIMs the notification above the options reads "New SIM inserted".

Build ID: 20140609000201
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/e3f85877db29
Gaia: 8b239e41bbd85aa7b6a2c5d388e775ba7de6fb2b
Platform Version: 30.0
Firmware Version: V10g-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Keywords: qawanted
Can we verify that we can reproduce this on the latest 2.0 Flame build?
Keywords: qawanted
The issue reproduce on the latest 2.0 Flame

Environmental Variables:
Device: Flame 2.0
Build ID: 20140610000223
Gaia: 8d865839d932bfbd5e157f376f74d8cb12bfdd51
Gecko: 1d4046a8cb6c
Version: 32.0a2 (2.0) 
Firmware Version: v10G-2
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Results so Far:
Flame 2.0 Repro
Flame 1.4 No Repro
Buri 2.0 Repro

QAWanted to Check Buri 1.4
Flags: needinfo?(jmitchell)
Keywords: qawanted
The issue does not occur on the latest Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140611000202
Gaia: d1cf95dc5e8b2f52148487291318542f1396608e
Gecko: a8bb6b76696b
Version: 30.0 (1.4) MOZ
Firmware Version: v1.2device.cfg
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA-Wanted for Regression Window
Flags: needinfo?(jmitchell)
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: --- → 2.0?

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
(Assignee)

Comment 11

4 years ago
Created attachment 8440628 [details] [review]
patch v1.0

Hi Salva,
would you mind reviewing the patch?
Regards
Attachment #8440628 - Flags: review?(salva)
(Assignee)

Updated

4 years ago
Assignee: nobody → mri
(Assignee)

Updated

4 years ago
Blocks: 977077
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1021141
Comment on attachment 8440628 [details] [review]
patch v1.0

Ok, thank you Mai!
Attachment #8440628 - Flags: review?(salva) → review+
(Assignee)

Comment 14

4 years ago
Master: 92d60c7aa2e821bbd88459f715d72e0f1af7c6f9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Removing QA-Wanted keywords as issue is resolved.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Keywords: regressionwindow-wanted
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S4 (20june)

Updated

4 years ago
Whiteboard: [2.0-FL-bug-bash] → [CR 674098][2.0-FL-bug-bash]

Updated

4 years ago
Whiteboard: [CR 674098][2.0-FL-bug-bash] → [caf priority: p2][CR 674098][2.0-FL-bug-bash]
Created attachment 8531858 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/5

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/29222e215db8
Build-ID        20141203000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        dbaf3e31c9ba9c3436e074381744f2971e15c7bf
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ebce587d2194
Build-ID        20141203001205
Version         34.0
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.