Closed Bug 1021548 Opened 7 years ago Closed 7 years ago

Importing second time from SIM card yields to errors in the console and contacts are not updated

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(tracking-b2g:backlog, b2g-v1.3 wontfix, b2g-v1.3T wontfix, b2g-v1.4 wontfix, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
tracking-b2g backlog
Tracking Status
b2g-v1.3 --- wontfix
b2g-v1.3T --- wontfix
b2g-v1.4 --- wontfix
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: jmcf, Assigned: jmcf)

References

Details

Attachments

(1 file)

STR: Go to Contacts App. Import your SIM Contacts. Everything is ok
Then, Import SIM Contacts another time. 

In the console can be found errors like this

Content JS ERROR at app://communications.gaiamobile.org/shared/js/contacts/import/utilities/import_sim_contacts.js:225 in saveError: SIM Import: Error importing  89340711002753192957 UnknownError

The Corresponding Contact is not saved nor updated.
QA Wanted to check 1.4.
Keywords: qawanted
Attached file 20232.html
Attachment #8436933 - Flags: review?(francisco)
Verified that this bug DOES repro on Flame 1.4. I get the same Errors in the log report when trying to reimport already imported contacts from the SIM.

SIM Import: Error importing  89014103255663540814210 UnknownError
06-09 17:24:43.281  1169  1169 E GeckoConsole: Content JS ERROR at app://communications.gaiamobile.org/contacts/js/utilities/import_sim_contacts.js:207 in saveError: SIM Import: Error importing  89014103255663540814209 UnknownError

Environmental Variables:
Device: Flame 1.4
Build ID: 20140609000201
Gaia: 8b239e41bbd85aa7b6a2c5d388e775ba7de6fb2b
Gecko: e3f85877db29
Version: 30.0 (1.4) 
Firmware Version: v10G-2
Keywords: qawanted
QA Contact: croesch
Target Milestone: --- → 2.0 S4 (20june)
(In reply to croesch from comment #3)
> Verified that this bug DOES repro on Flame 1.4. I get the same Errors in the
> log report when trying to reimport already imported contacts from the SIM.
> 
> SIM Import: Error importing  89014103255663540814210 UnknownError
> 06-09 17:24:43.281  1169  1169 E GeckoConsole: Content JS ERROR at
> app://communications.gaiamobile.org/contacts/js/utilities/
> import_sim_contacts.js:207 in saveError: SIM Import: Error importing 
> 89014103255663540814209 UnknownError
> 
> Environmental Variables:
> Device: Flame 1.4
> Build ID: 20140609000201
> Gaia: 8b239e41bbd85aa7b6a2c5d388e775ba7de6fb2b
> Gecko: e3f85877db29
> Version: 30.0 (1.4) 
> Firmware Version: v10G-2

Bug development by TEF team, for this reason I change QA contact.
QA Contact: croesch → lolimartinezcr
Comment on attachment 8436933 [details]
20232.html

Can we have unit tests for this, I know is a small change but with the current policy we should add always unit tests to our changes.

Code wise looks good to me, also tried on the phone and working.
Attachment #8436933 - Flags: review?(francisco) → review+
blocking-b2g: 2.0? → 1.4?
Jose,

So does this happen when the SAME set of contacts are imported OR does it happen when NEW contacts are imported?
Flags: needinfo?(jmcf)
QA Wanted to check 1.3.
Keywords: qawanted
(In reply to Preeti Raghunath(:Preeti) from comment #6)
> Jose,
> 
> So does this happen when the SAME set of contacts are imported OR does it
> happen when NEW contacts are imported?

It happens when the SAME set of contacts are imported
Flags: needinfo?(jmcf)
(In reply to Jason Smith [:jsmith] from comment #7)
> QA Wanted to check 1.3.

Verified that this bug DOES repro on Hamachi 1.3.

Gecko-8f64291
Gaia-7a69ecb
Keywords: qawanted
blocking-b2g: 1.4? → backlog
landed in master

https://github.com/mozilla-b2g/gaia/commit/07ab0bb6a6b26f4b0a2aaafb0c725f20464440de
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Keywords: verifyme
Flags: in-testsuite+
Tested and NOT working
Hamachi
2.1
Gecko-a3c4c53
Gaia-5f9f64a
Jose could you sync with Loli about this?
Flags: needinfo?(jmcf)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #12)
> Jose could you sync with Loli about this?

Jose and I have already talked about this bug.
(In reply to Loli from comment #13)
> (In reply to Francisco Jordano [:arcturus] [:francisco] from comment #12)
> > Jose could you sync with Loli about this?
> 
> Jose and I have already talked about this bug.

So, does the patch work? I doesnt?

We will need to know that to know if we backout the patch that doesnt work or is a small follow up.

Thanks!
Francisco,

The patch works partially. We have found that for certain contacts which are not merged they get duplicated. I'm currently investigating the issue and Loli will open a new bug that will try to fix asap

thanks
Flags: needinfo?(jmcf)
(In reply to Jose Manuel Cantera from comment #15)
> Francisco,
> 
> The patch works partially. We have found that for certain contacts which are
> not merged they get duplicated. I'm currently investigating the issue and
> Loli will open a new bug that will try to fix asap
> 
> thanks

Bug 1026369 opened to track this issue
Depends on: 1026369
Tested and working
Hamachi
2.1
Gecko:57d05d4
Gaia:846f561

Pending 2.0, 1,4 and 1.3
Tested and working
Hamachi 2.0
Gecko-c91e987
Gaia-87d0463

1.4
Gecko-b7cb7d7
Gaia-a054aa2
Status: RESOLVED → VERIFIED
(In reply to Loli from comment #18)
> Tested and working
> Hamachi 2.0
> Gecko-c91e987
> Gaia-87d0463
> 
> 1.4
> Gecko-b7cb7d7
> Gaia-a054aa2

Where I say tested in 2.0, it isn't correct. Pending uplift in 2.0, for this reason i change status to RESOLVED.
Status: VERIFIED → RESOLVED
Closed: 7 years ago7 years ago
Comment on attachment 8436933 [details]
20232.html

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Different behavior of mozContacts / iccManager between different versions of Gecko. 
[User impact] if declined: High, contacts can be duplicated or not updated, so the EX can be severely impacted. 
[Testing completed]: Yes, including unit testing. Tested by QA as well on v2.1 
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]:
Attachment #8436933 - Flags: approval-gaia-v2.0?
Attachment #8436933 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Tested and working
Hamachi 2.0
Gecko-bffdf5e
Gaia-2248c03
Status: RESOLVED → VERIFIED
Verified fixed on 2.0 and 2.1

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121000203
Gaia: 626d4d11a8c7e55022c1f364abb72ea340e2f1e7
Gecko: 74a294e72d0a
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141125001201
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Actual:
No errors occur and contacts with info get merged correctly
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.