Closed Bug 1021681 Opened 10 years ago Closed 10 years ago

Fix and re-enable test_played.html on B2G

Categories

(Core :: Audio/Video, defect)

29 Branch
ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1021794

People

(Reporter: RyanVM, Assigned: jwwang)

References

Details

This was disabled across the board back in bug 751539. However, it appears to pass on most platforms now except B2G.

https://tbpl.mozilla.org/php/getParsedLog.php?id=41178921&tree=Try

23:04:16     INFO -  1732 INFO TEST-PASS | /tests/content/media/test/test_played.html | start of first range shall be 0
23:04:16     INFO -  1733 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished seek.webm-30] Length of array should match number of running tests
23:04:16     INFO -  1734 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started owl.mp3-32] Length of array should match number of running tests
23:04:16     INFO -  1735 INFO TEST-PASS | /tests/content/media/test/test_played.html | element.played.length == 2
23:04:16     INFO -  1736 INFO TEST-PASS | /tests/content/media/test/test_played.html | we should have seeked forward by one tenth of the duration
23:04:16     INFO -  1737 INFO TEST-PASS | /tests/content/media/test/test_played.html | end of second range shall be the total duration
23:04:16     INFO -  1738 INFO TEST-PASS | /tests/content/media/test/test_played.html | start of first range shall be 0
23:04:16     INFO -  1739 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished owl.mp3-32] Length of array should match number of running tests
23:04:16     INFO -  1740 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started vbr.mp3-33] Length of array should match number of running tests
23:04:16     INFO -  1741 INFO TEST-PASS | /tests/content/media/test/test_played.html | element.played.length == 2
23:04:16     INFO -  1742 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_played.html | we should have seeked forward by one tenth of the duration
23:05:00     INFO -  1743 INFO TEST-INFO | dumping last 33 message(s)
23:05:00     INFO -  1744 INFO TEST-INFO | if you need more context, please use SimpleTest.requestCompleteLog() in your test
23:05:00     INFO -  1745 INFO TEST-PASS | /tests/content/media/test/test_played.html | end of second range shall be the total duration
23:05:00     INFO -  1746 INFO TEST-PASS | /tests/content/media/test/test_played.html | start of first range shall be 0
23:05:00     INFO -  1747 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished vbr.mp3-33] Length of array should match number of running tests
23:05:00     INFO -  1748 INFO TEST-PASS | /tests/content/media/test/test_played.html | element.played.length == 2
23:05:00     INFO -  1749 INFO TEST-PASS | /tests/content/media/test/test_played.html | we should have seeked forward by one tenth of the duration
23:05:00     INFO -  1750 INFO TEST-PASS | /tests/content/media/test/test_played.html | end of second range shall be the total duration
23:05:00     INFO -  1751 INFO TEST-PASS | /tests/content/media/test/test_played.html | start of first range shall be 0
23:05:00     INFO -  1752 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished gizmo.mp4-31] Length of array should match number of running tests
23:05:01     INFO -  1753 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started bug495794.ogg-34] Length of array should match number of running tests
23:05:01     INFO -  1754 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started big.wav-35] Length of array should match number of running tests
23:05:01     INFO -  1755 INFO TEST-PASS | /tests/content/media/test/test_played.html | start of first range shall be 0
23:05:01     INFO -  1756 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished bug495794.ogg-34] Length of array should match number of running tests
23:05:01     INFO -  1757 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started seek.ogv-36] Length of array should match number of running tests
23:05:01     INFO -  1758 INFO TEST-PASS | /tests/content/media/test/test_played.html | There should be at least one range
23:05:01     INFO -  1759 INFO TEST-PASS | /tests/content/media/test/test_played.html | Start of first range should be the sixth of the duration
23:05:01     INFO -  1760 INFO TEST-PASS | /tests/content/media/test/test_played.html | End of last range should be greater that five times the sixth of the duration
23:05:01     INFO -  1761 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished big.wav-35] Length of array should match number of running tests
23:05:01     INFO -  1762 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started seek.webm-37] Length of array should match number of running tests
23:05:01     INFO -  1763 INFO TEST-PASS | /tests/content/media/test/test_played.html | There should be at least one range
23:05:01     INFO -  1764 INFO TEST-PASS | /tests/content/media/test/test_played.html | Start of first range should be the sixth of the duration
23:05:01     INFO -  1765 INFO TEST-PASS | /tests/content/media/test/test_played.html | End of last range should be greater that five times the sixth of the duration
23:05:01     INFO -  1766 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished seek.ogv-36] Length of array should match number of running tests
23:05:01     INFO -  1767 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started gizmo.mp4-38] Length of array should match number of running tests
23:05:01     INFO -  1768 INFO TEST-PASS | /tests/content/media/test/test_played.html | There should be at least one range
23:05:01     INFO -  1769 INFO TEST-PASS | /tests/content/media/test/test_played.html | Start of first range should be the sixth of the duration
23:05:01     INFO -  1770 INFO TEST-PASS | /tests/content/media/test/test_played.html | End of last range should be greater that five times the sixth of the duration
23:05:01     INFO -  1771 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished seek.webm-37] Length of array should match number of running tests
23:05:01     INFO -  1772 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started owl.mp3-39] Length of array should match number of running tests
23:05:01     INFO -  1773 INFO TEST-PASS | /tests/content/media/test/test_played.html | There should be at least one range
23:05:01     INFO -  1774 INFO TEST-PASS | /tests/content/media/test/test_played.html | Start of first range should be the sixth of the duration
23:05:01     INFO -  1775 INFO TEST-PASS | /tests/content/media/test/test_played.html | End of last range should be greater that five times the sixth of the duration
23:05:01     INFO -  1776 INFO TEST-PASS | /tests/content/media/test/test_played.html | [finished owl.mp3-39] Length of array should match number of running tests
23:05:01     INFO -  1777 INFO TEST-PASS | /tests/content/media/test/test_played.html | [started vbr.mp3-40] Length of array should match number of running tests
23:05:01     INFO -  1778 INFO TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_played.html | Test timed out.
23:05:04     INFO -  1779 INFO TEST-INFO | MEMORY STAT vsize after test: 141615104
23:05:04     INFO -  1780 INFO TEST-INFO | MEMORY STAT residentFast after test: 56635392
23:05:04     INFO -  1781 INFO TEST-INFO | MEMORY STAT heapAllocated after test: 29911812
23:05:06     INFO -  1782 INFO TEST-END | /tests/content/media/test/test_played.html | finished in 333415ms
23:10:37     INFO -  B2GRunner TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_played.html | application timed out after 330.0 seconds with no output
Blocks: 1022453
Assignee: nobody → jwwang
Some failures are caused by wrong MP3 duration in bug 1023564.
Depends on: 1023564
Depends on: 1039901
No longer depends on: 1023564
Already fixed in bug 1021794.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.