[B2G][Homescreen]Scrolling multiple screens repeatedly leads to blurry icons on the homescreen

RESOLVED DUPLICATE of bug 1021507

Status

Firefox OS
Gaia::Homescreen
RESOLVED DUPLICATE of bug 1021507
4 years ago
4 years ago

People

(Reporter: JMercado, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected)

Details

(Whiteboard: [2.0-FL-bug-bash])

Attachments

(2 attachments)

Created attachment 8435901 [details]
firewatch_20140606_0953_blurry_icons.txt

Description:
Repeatedly scrolling multiple screens up and down will result in blurred icons at the bottom of the device. Scrolling more after the icons blur will fix this issue.


Repro Steps:
1) Update a Flame to 20140606040202
2) Rearrange the homescreen so that there are at least 12 categories (4 full screens)
3) Scroll in one swipe to the bottom of the screen
4) If issue does not occur, scroll to the top and immediately scroll back down in one swipe
5) Repeat 4 until issue occurs


Actual:
The icons at the bottom of the homescreen become blurred after the device stops scrolling


Expected:
Icons are always crisp when viewed.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140606040202
Gaia: 857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko: c8288d0c7a15
Version: 32.0a1 (2.0) 
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 50%
See attached: logcat, firewatch report, video
This issue does occur on Buri 2.0 as well.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140606040202
Gaia: 857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko: c8288d0c7a15
Version: 32.0a1 (2.0) 
Firmware Version: v10G-2

The icons on the homescreen blur if scrolling multiple screens repeatedly.
Created attachment 8435903 [details]
logcat_20140606_0953_blurry_icons.txt

Updated

4 years ago
Whiteboard: [2.0-FL-bug-bash]
Please see this video: http://youtu.be/xrvRYgcPUuw

Updated

4 years ago
Whiteboard: [2.0-FL-bug-bash]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1021507
You need to log in before you can comment on or make changes to this bug.