Corruption on Flash videos at www.weather.com

VERIFIED FIXED in mozilla32

Status

()

defect
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: streetwolf, Assigned: jwatt)

Tracking

({regression, reproducible})

32 Branch
mozilla32
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by partial backout of bug 965967], )

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140607033236

Steps to reproduce:

Play a video on www.weather.com.  Example:

http://www.weather.com/special/great-outdoors/video/is-this-heavens-gate-49424?collid=/video-minutes/great-outdoors


Actual results:

Black boxes appear when video starts.  Once the video begins hovering the mouse pointer over the video causes it to flicker.


Expected results:

Video should play with no corruption.
Based on regression testing I've found that Bug 965967 is the probable cause. Turning off OMTC fixes the problem.  Corruption doesn't happen on all Flash video sites. This bug might be graphic card/driver related.

Good: https://hg.mozilla.org/integration/mozilla-inbound/rev/7e7061043b85

Bad : https://hg.mozilla.org/integration/mozilla-inbound/rev/ca725c15bdeb


Graphics
--------

Adapter Description: AMD Radeon HD 7900 Series
Adapter Drivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 3072
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
Device ID: 0x6798
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.16384)
Driver Date: 5-22-2014
Driver Version: 14.200.0.0
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (AMD Radeon HD 7900 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Component: Untriaged → Graphics
Depends on: 965967
Keywords: regression
Product: Firefox → Core
Summary: Corruption on some Flash videos. → Corruption on Flash videos at www.weather.com
Confirming,  setting OMTC to 'false' prevents the black boxes jumping around during start of video.  I've not experienced this on other videos, at least none I've watched so far. 

Win7 x64 here 
Tested on m-c build cset:
https://hg.mozilla.org/mozilla-central/rev/62d33e3ba514

IE11 & Chrome play video normally without any small black boxes on start-up.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Another video that also show corruption, though not as bad as on weather.com, is at cnn.com.  Specifically, the video on the main page near the top left (Breaking News).  Other videos appear to be OK.
Looks fixed in latest hourly.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by partial backout of bug 965967]
(In reply to Virtual_ManPL [:Virtual] from comment #6)
> Looks fixed in latest hourly.

What latest hourly ? An hourly from m-i ?  Usually bugs are not marked 'Fixed', until it lands and sticks on m-c.
Hasn't merged to m-c yet.
Assignee: nobody → jwatt
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/45eeaf4173cd
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Duplicate of this bug: 1022401
Reproduced with Nightly 2014-06-07 and STR from comment 0.
Verified as fixed with Firefox 32 beta 4 (Build ID: 20140804164216) on Windows 7 x64:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.