Should not use egl fence sync on hamachi

RESOLVED FIXED in mozilla33

Status

()

Core
Graphics: Layers
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: sotaro, Assigned: sotaro)

Tracking

({regression})

unspecified
mozilla33
All
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #999694 +++

Bug 999694 add EGL fence support to SharedSurface_Gralloc. But we can not use this in ICS devices like hamachi. It can not do correct syncing.

WebGL rendeirng tearing could be observed by the following STR.
- [1] start crystalskull
- [2] touch screen and keep the skull rotating

This problem was already mentioned in Bug 843599 Comment 15 :-(
(Assignee)

Comment 1

4 years ago
Nominate to b2g-v1.4 It is a serious regression for ICS devices.
blocking-b2g: --- → 1.4?
(Assignee)

Comment 2

4 years ago
During [2] the problem seems more difficult to reproduce than before. It might be an effect from Bug 1006957.

Just after start up the crystalskull app, the problem seems easier to observe.
(Assignee)

Updated

4 years ago
Blocks: 999694
blocking-b2g: 1.4? → backlog
Is this applicable to KK or JB devices?
(Assignee)

Comment 4

4 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #3)
> Is this applicable to KK or JB devices?

This problem happens only on qcom ICS device.
(Assignee)

Updated

4 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 5

4 years ago
Created attachment 8443937 [details] [diff] [review]
patch - disable sync fence on AdrenoTM200

Confirmed the patch works on hamachi.
(Assignee)

Updated

4 years ago
Attachment #8443937 - Flags: review?(jgilbert)
Comment on attachment 8443937 [details] [diff] [review]
patch - disable sync fence on AdrenoTM200

Review of attachment 8443937 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/gl/SharedSurfaceGralloc.cpp
@@ +179,5 @@
>      // When Android native fences are available, try
>      // them first since they're more likely to work.
>      // Android native fences are also likely to perform better.
> +    if (!disableSyncFence &&
> +        mEGL->IsExtensionSupported(GLLibraryEGL::ANDROID_native_fence_sync)) {

Drop { to next line for multi-line conditionals.

@@ +204,5 @@
>          }
>      }
>  
> +    if (!disableSyncFence &&
> +        mEGL->IsExtensionSupported(GLLibraryEGL::KHR_fence_sync)) {

Drop { to next line for multi-line conditionals.
Attachment #8443937 - Flags: review?(jgilbert) → review+
https://hg.mozilla.org/mozilla-central/rev/ebac3a17de53
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla33
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.