Closed Bug 1022433 Opened 7 years ago Closed 7 years ago

Browser's domain-not-found message is missing the domain name ("Can't find the server at .")

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S5 (4july)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: dholbert, Assigned: albert)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

Attachments

(3 files)

STR:
 1. Visit http://aaaa.mozilla.org or some other nonexistent domain in the Firefox OS browser app.

ACTUAL RESULTS:
Browser displays this message:
> Server not found
> Can't find the server at .

EXPECTED RESULTS:
Looks like the domain name is supposed to be included between "at" and the "."



I'm using a Flame device, running a locally-built version of B2G trunk.
OS Version: 2.0.0.0-prerelease
Git commit info: 2014-06-08 87a937c5
(I also remember seeing this on an Unagi w/ B2G trunk a week or so ago, too.)
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → All
Also:
- Firefox OS 2.0 in the simulator reproduces the problem.
- Firefox OS 1.4 in the simulator works correctly. (It displays the domain name.)

So this is a regression.
Keywords: regression
QA Wanted - can we get a screenshot?
Component: Gaia::Browser → Gaia::System
Keywords: qawanted
blocking-b2g: --- → 2.0?
Component: Gaia::System → Gaia::System::Window Mgmt
Whiteboard: [systemsfe]
blocking-b2g: 2.0? → 2.0+
QA Contact: jmitchell
B2G Inbound Regression Window:

Last Working:
Environmental Variables:
Device: Flame Master
Build ID: 20140417180011
Gaia: e3474caf17e7e2a30e5d99f29dbf3413cb24cc12
Gecko: e224847eaf96
Version: 31.0a1 (Master) 
Firmware Version: v10G-2

First Broken:
Environmental Variables:
Device: Flame Master
Build ID: 20140418000002
Gaia: acfa2cccdbd7d23c9b51a930be78f7ef19a6b925
Gecko: 9772ba4d13bf
Version: 31.0a1 (Master) 
Firmware Version: v10G-2

Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e3474caf17e7e2a30e5d99f29dbf3413cb24cc12
Gecko: 9772ba4d13bf

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: acfa2cccdbd7d23c9b51a930be78f7ef19a6b925
Gecko: e224847eaf96

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e3474caf17e7e2a30e5d99f29dbf3413cb24cc12...acfa2cccdbd7d23c9b51a930be78f7ef19a6b925
Thanks. Given that range, looks likely to be a regression from bug 912445. ("Show specific information when there is a server connection issue with an application")
Blocks: 912445
Albert, looks like your patch in bug 912445 may have caused this. Do you have cycles to take a look at this? (or can you suggest someone who might?)
Flags: needinfo?(acperez)
(In reply to Daniel Holbert [:dholbert] from comment #7)
> Albert, looks like your patch in bug 912445 may have caused this. Do you
> have cycles to take a look at this? (or can you suggest someone who might?)

I can work on it.
Flags: needinfo?(acperez)
Assignee: nobody → acperez
I found the root problem and have a fix for it but I'm not able to reproduce the bug. When I open a wrong url the browser shows a blank page instead of the error page. Tried master and 1.4.
Depends on: 1023742
No longer depends on: 1023742
Duplicate of this bug: 1023742
Depends on: 1023742
Target Milestone: --- → 2.0 S4 (20june)
Attached file Patch
Attachment #8439818 - Flags: review?(mhenretty)
Duplicate of this bug: 1027237
Target Milestone: 2.0 S4 (20june) → 2.0 S5 (4july)
Comment on attachment 8439818 [details]
Patch

Code looks good, and I can confirm this fixes the issue. Good work!

Albert, please add a unit test that would fail before adding this patch. Then I think we are good to land.
Attachment #8439818 - Flags: review?(mhenretty) → review+
(In reply to Michael Henretty [:mhenretty] from comment #13)
> Comment on attachment 8439818 [details]
> Patch
> 
> Code looks good, and I can confirm this fixes the issue. Good work!
> 
> Albert, please add a unit test that would fail before adding this patch.
> Then I think we are good to land.

Tests added and travis is green.
Master: https://github.com/mozilla-b2g/gaia/commit/1412afd61342da6a0517c7bd2e5e22ef57715517
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified the issue is fixed on 2.1 and 2.0 Flame builds

"Server" not found" message appears with complete address 

Device: Flame 2.1
BuildID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Device: Flame 2.0
BuildID: 20141103000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
  
Notes:
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.