Update platform/bootable/recovery in tarako manifest

RESOLVED FIXED in Firefox OS v1.3T

Status

--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: seinlin, Assigned: seinlin)

Tracking

unspecified
2.0 S4 (20june)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed, b2g-v1.4 wontfix, b2g-v2.0 fixed)

Details

Attachments

(2 attachments)

52 bytes, text/x-github-pull-request
james.zhang
: review+
Details | Review | Splinter Review
52 bytes, text/x-github-pull-request
james.zhang
: review+
Details | Review | Splinter Review
(Assignee)

Description

4 years ago
Partner has a specific branch of platform/bootable/recovery for tarako, need to update platform/bootable/recovery in tarako manifest.
(Assignee)

Comment 1

4 years ago
Created attachment 8436634 [details] [review]
PR for master

Michael, can you review this patch? Thanks!
Attachment #8436634 - Flags: review?(mwu)
(Assignee)

Comment 2

4 years ago
Created attachment 8436636 [details] [review]
PR for v1.3t
(Assignee)

Updated

4 years ago
Depends on: 1017735
(Assignee)

Comment 3

4 years ago
I think it should block 1.3T, as this update is for Tarako.
blocking-b2g: --- → 1.3T?
I have merge Kaizhen's patch to v1.3t.

v1.3t 4a8829a932ffcd22f11f9e2e3b5351f3a0925f85
Assignee: nobody → kli
Status: NEW → ASSIGNED
status-b2g-v1.3T: --- → fixed
status-b2g-v1.4: --- → wontfix
status-b2g-v2.0: --- → affected

Comment 5

4 years ago
Comment on attachment 8436634 [details] [review]
PR for master

Ask James Zhang for review on tarako manifest changes next time.
Attachment #8436634 - Flags: review?(mwu)
Attachment #8436634 - Flags: review+
Attachment #8436636 - Flags: review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Master: https://github.com/mozilla-b2g/b2g-manifest/commit/423937d151ad93d5d1ee6c37be12b4e8f6c7f79f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.0: affected → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
I'm confused.  Should this have landed before it was nom'ed?
Flags: needinfo?(bbajaj)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #7)
> I'm confused.  Should this have landed before it was nom'ed?

not really, comment #4 broke the rules.
James,can you please help understand what happened here as it breaks our general workflow. If we have critical landings to be done on the branch, can we escalate the issue to Steven/Joe so they can act on the blocking flags ?
Flags: needinfo?(bbajaj)

Updated

4 years ago
blocking-b2g: 1.3T? → 1.3T+
Steven told us that spreadtrum can land anything on v1.3t.
This change is from my side and bug 1017735.
Actually it's all spreadtrum's change.
Well, the problem is that we do need to be notified in the event that this may impact our builds for testing. Changing the 1.3T? to 1.3T+ would help.

To note, we locked the recovery to an old revision because it caused a breakage in our builds; see bug 1023353.  I am not sure if that is the right fix, our builds work now.  Having said that we do not get the new logos.
Flags: needinfo?(james.zhang)
Flags: needinfo?(james.zhang)
You need to log in before you can comment on or make changes to this bug.