Closed Bug 1022850 Opened 7 years ago Closed 7 years ago

[B2G][SMS][Messaging] MMS unable to send when Wifi/Data is disconnected

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

RESOLVED WORKSFORME
Tracking Status
b2g-v1.3 --- affected
b2g-v1.4 --- affected
b2g-v2.0 --- affected
b2g-v2.1 --- affected

People

(Reporter: bmorgan, Assigned: bevis)

Details

(Whiteboard: [2.0-flame-test-run-2])

Attachments

(2 files)

Attached file logcat buri 1-3.txt
Description:
When the Wifi and Data connections are disconnected, the device is unable to send an MMS.


Repro Steps:
1) Update a Flame to 20140609040203
2) Pull down the notifications bar and turn off Wifi and Data
3) Open the messaging app, enter a contact name or number, attach a picture, and press send.
4) Observe an "Unable to send" error message.


Actual:
Flame - MMS times out after 5 minutes, does not send message.

Expected:
MMS will process and send


Environmental Variables:
Device: Flame 2.0
Build ID: 20140609040203
Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
Gecko: 9305a8ec77fe
Version: 32.0a1 (2.0) MOZ
Firmware Version: v10G-2

User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Repro frequency: 100%
See attached: logcat

Flame logcat issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1010993
With WiFi and Data disconnected, the MMS continues trying to send until interrupted on the Buri 1.3 MOZ RIL

1.3 Environmental Variables:
Device: Buri 1.3
Build ID: 20140607024002
Gaia: e049de79ff46fcab51f29a88d5869c5efb48fc3c
Gecko: 90e7f697961a
Version: 28.0 (1.3) MOZ
Firmware Version: v1.2device.cfg

My User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
Component: Gaia::SMS → RIL
Assignee: nobody → btseng
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.0-flame-test-run-2]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Sorry for late response of this bug.

after comparing the comment 66 and comment 67 in bug 1003247, it seems that the problem is actually verified fix in build-ID 20140527040202 in comment 66 but is now reproducible in comment 0 of this bug with build-ID 20140609040203.

Set regression-wanted to see if there is any regression cause this problem.
(In reply to Bevis Tseng [:bevistseng] (btseng@mozilla.com) from comment #2)
> Sorry for late response of this bug.
> 
> after comparing the comment 66 and comment 67 in bug 1003247, it seems that
> the problem is actually verified fix in build-ID 20140527040202 in comment
> 66 but is now reproducible in comment 0 of this bug with build-ID
> 20140609040203.
> 
BTW, the test device I am talking about is Flame with 2.0 build.
> Set regression-wanted to see if there is any regression cause this problem.
Asking qawanted here to check branches here again, since Bevis's comments above imply that the branch testing might be incorrect.
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
QA Contact: ckreinbring
This bug does not reproduce on Buri 1.4.

Build ID: 20140626000203
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/e054ac1b5408
Gaia: a054aa221df20ca550e6c67f3fbb20d0ad086598
Platform Version: 30.0
Firmware Version: V1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Actual result: The MMS is sent after a few seconds, depending on the size of the attachment.

-------------------------------------------------------------------------------------------------------

This bug reproduces on Flame 2.1, Flame 2.0, Flame 1.4 and Open C 1.4

2.1 Flame
Build ID: 20140627040205
Gecko: https://hg.mozilla.org/mozilla-central/rev/9290d7995f98
Gaia: b8f36518696f3191a56e4f33447ee9d6ec820da1
Platform Version: 33.0a1
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

2.0 Flame
Build ID: 20140625000201
Gecko: https://hg.mozilla.org/releases/mozilla-aurora/rev/79712bd7b60d
Gaia: de77f794db22a45f9d575de2c6e266a30a50de3b
Platform Version: 32.0a2
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

1.4 Flame
Build ID: 20140627000201
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/d956b3a3e921
Gaia: 76e669c6fa387f97bcaaaee5d179ee4a9dcca986
Platform Version: 30.0
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

1.4 Open C
Build ID: 20140625000201
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/cddf88f78632
Gaia: c9416de14acf9e94ab006619cd2418c768422fcb
Platform Version: 30.0
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Thanks for the testing.
Due to the new policy of not going to run Moz RIL in flame device,
can we have the same test on Buri 2.0/2.1 and collect the logcat & tcpdump with the instruction below if it still happens on Buri 2.0/2.1 as well for further analysis?
https://github.com/bevis-tseng/Debug_Tools

Thanks again!
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
(In reply to Bevis Tseng [:bevistseng] (btseng@mozilla.com) from comment #6)
> Thanks for the testing.
> Due to the new policy of not going to run Moz RIL in flame device,
> can we have the same test on Buri 2.0/2.1 and collect the logcat & tcpdump
> with the instruction below if it still happens on Buri 2.0/2.1 as well for
> further analysis?
> https://github.com/bevis-tseng/Debug_Tools
> 
> Thanks again!

This issue does NOT reproduce in the latest Buri 2.0/2.1 branch builds:

Environmental Variables
Device: Buri 2.1
BuildID: 20140709040203
Gaia: 0f9f11d0a6dadb3ea27160204bbe911c1ad69a6f
Gecko: 196d05832e12
Version: 33.0a1 
Firmware Version: V1.2-device.cfg
2.1 - Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Environmental Variables:
Device: Buri 2.0
BuildID: 20140709000201
Gaia: 1dd043857399c713e3b509c0ed31bdf20326f08b
Gecko: 0b5f757da75a
Version: 32.0a2
Firmware Version: V1.2-device.cfg
2.0 - Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

The MMS successfully sends and is received properly by other test devices when WiFi and Data are not enabled.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Bevis, should we close this WORKSFORME ?
Flags: needinfo?(btseng)
According to comment 7, Yes.
Thanks for reminding.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(btseng)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.