Esc key both opens console and continues debugger, resulting in confusion

RESOLVED DUPLICATE of bug 957174

Status

RESOLVED DUPLICATE of bug 957174
5 years ago
6 months ago

People

(Reporter: website, Unassigned)

Tracking

29 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8437360 [details]
Breakpoint, press escape, didn't notice debugger continued

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.114 Safari/537.36

Steps to reproduce:

Firefly 29.0.1. Mac OS X 10.8.4

1. Place breakpoint in javascript
2. Hit breakpoint
3. Press "Esc" to open console
4. Type variable name to inspect


Actual results:

ReferenceError, because the debugger continued without me noticing and the variable is no longer in scope.


Expected results:

Console opens, but debugger remains paused so variables can be inspected.

This is debatable, but as you can see from the attached gif it's not obvious that the debugger has continued running, especially as one's attention is on the console, not the pause/skip/continue buttons at the top.
Component: Untriaged → Developer Tools: Debugger
I can confirm via hitting BP, but not via just hitting the pause button. Seeing these two messages in the console:

A promise chain failed to handle a rejection.
Full Message: TypeError: cm.lineInfo(...) is null debugger.js:107

"Couldn't evaluate: No stack frame available." debugger-panes.js:1917

First message is the same as bug 1013948, but I don't know if this is the same issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Thanks for the bug report!
I don't see the problem when hit from the debugger keyword or breakpoint on this page: http://htmlpad.org/debugger/.  Does this depend on the script?
(In reply to Brian Grinstead [:bgrins] from comment #3)
> I don't see the problem when hit from the debugger keyword or breakpoint on
> this page: http://htmlpad.org/debugger/.  Does this depend on the script?

I can repro by setting a BP on line 7 (first non-comment line) of autocomplete-min.js on this page, refreshing to hit the BP, hitting ESC.
(In reply to Nick Fitzgerald [:fitzgen] from comment #4)
> (In reply to Brian Grinstead [:bgrins] from comment #3)
> > I don't see the problem when hit from the debugger keyword or breakpoint on
> > this page: http://htmlpad.org/debugger/.  Does this depend on the script?
> 
> I can repro by setting a BP on line 7 (first non-comment line) of
> autocomplete-min.js on this page, refreshing to hit the BP, hitting ESC.

Oddly, I can't seem to get ESC to do anything in that case (doesn't open split console at all).  May be unrelated and due to bug 1022765
I can reproduce this too.
(In reply to Victor Porof [:vporof][:vp] from comment #7)
> Also, bug 957174.

I think this might be a dupe of that bug, but I'd need to dig further to be sure.
It does look like the same bug, indeed. I'm looking into it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 957174

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.