Closed Bug 1023270 Opened 6 years ago Closed 6 years ago

Three-dot menu and + button are redundant in tabs tray

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 33
Tracking Status
firefox33 --- verified
fennec 33+ ---

People

(Reporter: Margaret, Assigned: liuche)

References

Details

Attachments

(2 files)

Splitting this off from bug 817716. We can explore solutions here.
Bug 1018432 and bug 1023331 add telemetry for these two items, so we could wait on some data before deciding what to do here. Or we could make a gut call and remove the + button, but I'm not sure that's necessary.
Many users do not enable telemetry.

I don't know whether the proposal is for the "+" button to be replaced with something else, but I find it very convenient to press the tabs button and then in the exact same spot press the "+" for a new tab.

Of course an even better solution could be to always make the "+" button visible, i.e. one less click for one of the most widely used actions but at the risk of cluttering the interface.
Yeah, I tend to agree with bug.zilla here. 

We can look at being clever and removing redundant items *inside* the new menu we've added, but I don't want to remove the "+" from the title bar as its purpose is to provide an immediate action without having to go into a menu.
Duplicate of this bug: 1030682
tracking-fennec: --- → ?
Assignee: margaret.leibovic → liuche
Based on UI Telemetry, the "+" button is very heavily used. So if we decide to make a change it would seem to make sense to hide the menu item.
Ian - a screenshot where we're showing the "Add * tab" menu item that isn't already handled by the panel's + button. Seem good?
Flags: needinfo?(ibarlow)
(In reply to Chenxia Liu [:liuche] from comment #6)
> Created attachment 8449929 [details]
> Screenshot: Menu for private tabs panel
> 
> Ian - a screenshot where we're showing the "Add * tab" menu item that isn't
> already handled by the panel's + button. Seem good?

Thumbs up!
Flags: needinfo?(ibarlow)
Attachment #8449931 - Flags: review?(mark.finkle) → review+
tracking-fennec: ? → 33+
https://hg.mozilla.org/integration/fx-team/rev/efeceedf29e8
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 33
https://hg.mozilla.org/mozilla-central/rev/efeceedf29e8
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Verified as fixed in build:
Firefox for Android 33.0a1 (2014-07-04)
Device:
Asus Transformer Pad TF300T (Android 4.2.1)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.