Closed Bug 1023684 Opened 6 years ago Closed 6 years ago

[Meta] CMAS Alerts

Categories

(Firefox OS Graveyard :: Gaia::Network Alerts, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bhuang, Unassigned)

References

Details

(Whiteboard: [2.1-feature-qa+])

User Story

As a user, I want to be able to receive and display CMAS alerts in order to be able to quickly act on them if there is an emergency.
This meta bug tracks the overall implementation of CMAS.  Will open up more dependent stories once we clarify the areas that it touches such as settings, message, system.
I think bug 971312 is related to this topic.
Depends on: 971312
Depends on: 1032651
QA Whiteboard: [2.1-feature-qa+]
Duplicate of this bug: 971312
Flags: in-moztrap?(ashiue)
QA Contact: ashiue
QA Whiteboard: [2.1-feature-qa+]
Whiteboard: [2.1-feature-qa+]
Flags: in-moztrap?(ashiue) → in-moztrap?
QA Contact: ashiue
Flags: in-moztrap? → in-moztrap?(echang)
QA Contact: echang
1. Check for CMAS switch in Settings
https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=100&sortfield=created_on&sortdirection=desc&filter-tag=3000
2. Mochitest on emulator.

P.S. Currently we do not have env for testing cell broadcast and cmas.
Flags: in-moztrap?(echang) → in-moztrap+
Wesley - Is this feature completely landed? If so, can we close this bug out?
Flags: needinfo?(whuang)
QA Whiteboard: [2.1-feature-slip?]
Yes. Since all dependent bugs are resolved.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(whuang)
Resolution: --- → FIXED
QA Whiteboard: [2.1-feature-slip?]
According to Eric this was verified in bug 1026685's testing.
Status: RESOLVED → VERIFIED
Component: Gaia::Settings → Gaia::Network Alerts
You need to log in before you can comment on or make changes to this bug.