Canceling the UI flow should clean up pending content requests

VERIFIED FIXED in Firefox OS v2.0

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

unspecified
2.0 S4 (20june)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

Details

(Whiteboard: ft:loop)

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Canceling the Mobile ID UI flow leaves some pending content requests that makes the next run of the flow unstable.
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
Whiteboard: ft:loop
(Assignee)

Updated

4 years ago
Component: DOM: Device Interfaces → Gaia::System
Product: Core → Firefox OS
(Assignee)

Comment 1

4 years ago
Without this fix the mobile ID flow can't be used if the user cancels the flow once unless the user reboots the device, so I think it is worth taking the fix for 2.0.
blocking-b2g: --- → 2.0?
(Assignee)

Comment 2

4 years ago
Created attachment 8442032 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/20684
Attachment #8442032 - Flags: review?(alive)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1023853

Updated

4 years ago
blocking-b2g: 2.0? → 2.0+
Attachment #8442032 - Flags: review?(alive) → review+
(Assignee)

Comment 4

4 years ago
Thanks Alive!

https://github.com/mozilla-b2g/gaia/commit/df6ab5855378dfd874fa69630a49cffcb4117111
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
v2.0: https://github.com/mozilla-b2g/gaia/commit/0e788189b5490db66f11be2f655c2c2b2c215781
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → fixed
Target Milestone: --- → 2.0 S4 (20june)
Fernando,

Could you please provide the detailed reproduce steps for me to verify this bug?
Thank you very much!
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 7

4 years ago
Hello Lancy,

if you are using an engineering build, you can trigger the Mobile ID flow from the "MobileIdentity" test from the "UITest privileged" app. You should be able to open the flow by clicking in any of the two buttons "Get assertion" or "Force selection". Once the flow is opened, you should be able to cancel it by clicking in the "X" button in the top left corner. Cancelling the flow should not affect the following launch and so you should be able to complete the flow and obtain the Mobile ID assertion.

If you are not using an engineering build, you can install the FxOS Loop client (https://github.com/mozilla-b2g/firefoxos-loop-client) that makes use of this API and follow the same process of triggering and cancelling the Mobile ID flow.
Flags: needinfo?(ferjmoreno)
Created attachment 8531036 [details]
Verify_Video_Flame.MP4

This issue has been verified successfully on Flame 2.0 & 2.1.
See attachment: Verify_Video_Flame.MP4
Reproducing rate: 0/5

Flame v2.0 version:
Gaia-Rev        8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/c756bd8bf3c3
Build-ID        20141201000201
Version         32.0

Flame v2.1 version:
Gaia-Rev        ccb49abe412c978a4045f0c75abff534372716c4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/18fb67530b22
Build-ID        20141201001201
Version         34.0
status-b2g-v2.0: fixed → verified
status-b2g-v2.1: fixed → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.