Die in configure if building with less than SDK 17 (not 19)

RESOLVED FIXED in Firefox 33

Status

()

Firefox for Android
Build Config & IDE Support
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

Trunk
Firefox 33
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 8438814 [details] [diff] [review]
Die in configure if building with less than SDK 19. v1

Tested with 17 and 19 on Mac.
Attachment #8438814 - Flags: review?(nalexander)
Backed out in https://hg.mozilla.org/integration/fx-team/rev/4ed277e051da for Android build bustage:

https://tbpl.mozilla.org/php/getParsedLog.php?id=41563690&tree=Fx-Team

"configure: error: The given Android SDK provides API level 17 (19 or higher required)."
Flags: needinfo?(rnewman)
(Assignee)

Comment 4

4 years ago
So then I guess Nick was right when he said 17 was enough! And indeed the docs say he's right. Relanding with 17, not 19.
Flags: needinfo?(rnewman)
(Assignee)

Comment 6

4 years ago
Aaaand I'm going to let that incorrect commit message slide. Sigh.
Summary: Die in configure if building with less than SDK 19 → Die in configure if building with less than SDK 17 (not 19)
https://hg.mozilla.org/mozilla-central/rev/35668b465d00
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
Comment on attachment 8438814 [details] [diff] [review]
Die in configure if building with less than SDK 19. v1

Review of attachment 8438814 [details] [diff] [review]:
-----------------------------------------------------------------

This landed, clearing flag.
Attachment #8438814 - Flags: review?(nalexander)
Duplicate of this bug: 812227
(Assignee)

Updated

4 years ago
Blocks: 1122024
You need to log in before you can comment on or make changes to this bug.